summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f216dd26ec5..0339f1fea801 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = pikaur
pkgdesc = AUR helper with minimal dependencies inspired by pacaur, yaourt and yay. Review PKGBUILDs all in once, next build them all without user interaction.
- pkgver = 0.15.1
+ pkgver = 1.0
pkgrel = 1
url = https://github.com/actionless/pikaur
arch = any
license = GPL3
- depends = pacman>=5.1
+ makedepends = ruby-ronn
+ depends = pacman
depends = pyalpm
depends = git
conflicts = pikaur-git
- source = pikaur-0.15.1.tar.gz::https://github.com/actionless/pikaur/archive/0.15.1.tar.gz
- md5sums = 0dde489da70e25a8cd1cc3eeb6662c3c
+ source = pikaur-1.0.tar.gz::https://github.com/actionless/pikaur/archive/1.0.tar.gz
+ md5sums = 4b75fd3193e2b71822d058500d42229c
pkgname = pikaur
diff --git a/PKGBUILD b/PKGBUILD
index 2cc7de2f4c7a..ffaaec05864d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# shellcheck disable=SC2034,SC2154
pkgname=pikaur
-pkgver=0.15.1
+pkgver=1.0
pkgrel=1
pkgdesc="AUR helper with minimal dependencies inspired by pacaur, yaourt and yay. Review PKGBUILDs all in once, next build them all without user interaction."
arch=('any')
@@ -11,12 +11,15 @@ license=('GPL3')
source=(
"$pkgname-$pkgver.tar.gz"::https://github.com/actionless/pikaur/archive/"$pkgver".tar.gz
)
-md5sums=('0dde489da70e25a8cd1cc3eeb6662c3c')
+md5sums=('4b75fd3193e2b71822d058500d42229c')
depends=(
- 'pacman>=5.1'
+ 'pacman'
'pyalpm'
'git'
)
+makedepends=(
+ 'ruby-ronn'
+)
conflicts=('pikaur-git')
build() {
@@ -33,5 +36,6 @@ package() {
install -Dm644 "locale/${langmo}" "$pkgdir/usr/share/locale/${lang}/LC_MESSAGES/pikaur.mo"
done
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 pikaur.1 "$pkgdir/usr/share/man/man1/pikaur.1"
cp -r ./packaging/* "${pkgdir}"
}