summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a1256570bee1..ff0f1dbb4336 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pikaur
pkgdesc = AUR helper which asks all questions before installing/building. Inspired by pacaur, yaourt and yay.
pkgver = 1.5.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/actionless/pikaur
arch = any
license = GPL3
@@ -9,6 +9,7 @@ pkgbase = pikaur
depends = git
optdepends = asp: for ABS support in -G/--getpkgbuild operation
optdepends = python-pysocks: for socks5 proxy support
+ provides = pikaur
conflicts = pikaur-git
source = pikaur-1.5.2.tar.gz::https://github.com/actionless/pikaur/archive/1.5.2.tar.gz
md5sums = 2847e94d4dcaebc1d71b4a4ff060d2ec
diff --git a/PKGBUILD b/PKGBUILD
index bd13dc505d29..14437f86a989 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=pikaur
pkgver=1.5.2
-pkgrel=1
+pkgrel=2
pkgdesc="AUR helper which asks all questions before installing/building. Inspired by pacaur, yaourt and yay."
arch=('any')
url="https://github.com/actionless/pikaur"
@@ -21,6 +21,7 @@ optdepends=(
'python-pysocks: for socks5 proxy support'
)
conflicts=('pikaur-git')
+provides=('pikaur')
build() {
cd "${srcdir}/${pkgname}-${pkgver}" || exit 2
@@ -30,7 +31,7 @@ build() {
package() {
cd "${srcdir}/${pkgname}-${pkgver}" || exit 2
- python3 setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
+ /usr/bin/python3 setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
for langmo in $(cd ./locale && ls ./*.mo); do
lang=$(sed -e 's/.mo$//' <<< "${langmo}")
install -Dm644 "locale/${langmo}" "$pkgdir/usr/share/locale/${lang}/LC_MESSAGES/pikaur.mo"