summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG5
-rw-r--r--PKGBUILD4
3 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5ccb20a40c5..b8634ade75cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pikaur
pkgdesc = AUR helper with minimal dependencies inspired by pacaur, yaourt and yay. Review PKGBUILDs all in once, next build them all without user interaction.
- pkgver = 1.2.6
+ pkgver = 1.2.7
pkgrel = 1
url = https://github.com/actionless/pikaur
arch = any
@@ -10,8 +10,8 @@ pkgbase = pikaur
depends = git
optdepends = asp: for ABS support in -G/--getpkgbuild operation
conflicts = pikaur-git
- source = pikaur-1.2.6.tar.gz::https://github.com/actionless/pikaur/archive/1.2.6.tar.gz
- md5sums = f3e2066dbdc668d8a39867cbaa9e7f72
+ source = pikaur-1.2.7.tar.gz::https://github.com/actionless/pikaur/archive/1.2.7.tar.gz
+ md5sums = bcec3f76055105944410f9c6210b4a55
pkgname = pikaur
diff --git a/CHANGELOG b/CHANGELOG
index 4e9f4494ccc8..7ec9f1fa9b55 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -314,3 +314,8 @@
2018-07-28 e68d2ec actionless fix(install info fetcher): inprecise prompt when package_A depends on package_B and package_C (provided by package_B)
2018-07-28 3b01361 actionless feat: implement --dynamic-users flag and config option
2018-07-27 b7bce43 actionless feat(aur: get_json_from_url): better exception text
+1.2.7 Release 1.2.7
+
+ 2018-07-28 d2d318b feat(config): add `ui.PrintCommands` to print each command which pikaur spawning
+ 2018-07-28 d862f96 refactor(main): use `sudo -v` instead of `sudo pacman -T` for a sudo loop
+ 2018-07-28 59e544a fix(args): don't use `-r` args since it's 'undeprecated' in pacman
diff --git a/PKGBUILD b/PKGBUILD
index cbe13fd91d2a..95932f776e0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# shellcheck disable=SC2034,SC2154
pkgname=pikaur
-pkgver=1.2.6
+pkgver=1.2.7
pkgrel=1
pkgdesc="AUR helper with minimal dependencies inspired by pacaur, yaourt and yay. Review PKGBUILDs all in once, next build them all without user interaction."
arch=('any')
@@ -11,7 +11,7 @@ license=('GPL3')
source=(
"$pkgname-$pkgver.tar.gz"::https://github.com/actionless/pikaur/archive/"$pkgver".tar.gz
)
-md5sums=('f3e2066dbdc668d8a39867cbaa9e7f72')
+md5sums=('bcec3f76055105944410f9c6210b4a55')
depends=(
'pacman'
'pyalpm'