summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--CHANGELOG14
-rw-r--r--PKGBUILD7
3 files changed, 22 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 947affd17b58..525ddcced564 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pikaur
pkgdesc = AUR helper which asks all questions before installing/building. Inspired by pacaur, yaourt and yay.
- pkgver = 1.4.1
+ pkgver = 1.4.2
pkgrel = 1
url = https://github.com/actionless/pikaur
arch = any
@@ -8,9 +8,10 @@ pkgbase = pikaur
depends = pyalpm
depends = git
optdepends = asp: for ABS support in -G/--getpkgbuild operation
+ optdepends = python-pysocks: for socks5 proxy support
conflicts = pikaur-git
- source = pikaur-1.4.1.tar.gz::https://github.com/actionless/pikaur/archive/1.4.1.tar.gz
- md5sums = c1c476894d1a9e994256dbb0f0c6ebe0
+ source = pikaur-1.4.2.tar.gz::https://github.com/actionless/pikaur/archive/1.4.2.tar.gz
+ md5sums = 8117dc826b853775356de93ece115586
pkgname = pikaur
diff --git a/CHANGELOG b/CHANGELOG
index 78d47e3211c0..3b2fd21dfb90 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1374,3 +1374,17 @@ Wed Mar 20 01:10:16 2019 +0100
2019-03-15 e63f7d6 Jason doc(readme): Amend spelling mistake (#352)
2019-03-14 3edafac actionless fix(install_cli: get_installed_status, review_build_files): if aur repo didn't changed and --needed or --devel is used mark package as already reviewed
2019-03-05 9654ef2 Drommer Full russian translation (#355)
+
+
+Mon Apr 22 01:46:29 2019 +0200
+-------------------------------------------------
+1.4.2 Release 1.4.2
+
+ Notable changes:
+ 2019-04-16 89f2ec4 actionless fix(version, print deps): hope it's the last versiondiff fix :D
+ 2019-04-13 ef5964f Jakob Petsovits Invoke python3 instead of python in PKDBUILD package() script.
+ 2019-04-04 5b45aeb actionless feat(install cli: _get_installed_status): print warning when skipping --devel pkgs' review
+ 2019-04-02 2628631 actionless feat(version, print_dept): cover more sidecases of versiondiff sorting when showing available upgrades
+ 2019-03-26 2c3d678 lrh2000 Add `[e] edit PKGBUILD` option when failing to build packages.
+ 2019-03-26 4469752 lrh2000 Add Socks5Proxy option in the config file.
+ 2019-03-26 b3df0c6 actionless fix(prompt): handle EOF the same as Ctrl+C
diff --git a/PKGBUILD b/PKGBUILD
index fa0ae9ba864c..63e9196d56d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# shellcheck disable=SC2034,SC2154
pkgname=pikaur
-pkgver=1.4.1
+pkgver=1.4.2
pkgrel=1
pkgdesc="AUR helper which asks all questions before installing/building. Inspired by pacaur, yaourt and yay."
arch=('any')
@@ -11,13 +11,14 @@ license=('GPL3')
source=(
"$pkgname-$pkgver.tar.gz"::https://github.com/actionless/pikaur/archive/"$pkgver".tar.gz
)
-md5sums=('c1c476894d1a9e994256dbb0f0c6ebe0')
+md5sums=('8117dc826b853775356de93ece115586')
depends=(
'pyalpm'
'git'
)
optdepends=(
'asp: for ABS support in -G/--getpkgbuild operation'
+ 'python-pysocks: for socks5 proxy support'
)
conflicts=('pikaur-git')
@@ -29,7 +30,7 @@ build() {
package() {
cd "${srcdir}/${pkgname}-${pkgver}" || exit 2
- python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
+ python3 setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
for langmo in $(cd ./locale && ls ./*.mo); do
lang=$(sed -e 's/.mo$//' <<< "${langmo}")
install -Dm644 "locale/${langmo}" "$pkgdir/usr/share/locale/${lang}/LC_MESSAGES/pikaur.mo"