summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4f298c227d71
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pillowtalk-git
+ pkgdesc = ANSI C library that talks to CouchDB using libcurl and yajl
+ pkgver = 0.3.r29.ga2323dc
+ pkgrel = 1
+ url = https://github.com/mgmarino/pillowtalk
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ depends = curl
+ depends = yajl
+ options = strip
+ source = pillowtalk-git::git+https://github.com/mgmarino/pillowtalk.git
+ md5sums = SKIP
+
+pkgname = pillowtalk-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d0f0e1cf35a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Iblis Lin <e196819@hotmail.com>
+
+pkgname=pillowtalk-git
+pkgver=0.3.r29.ga2323dc
+pkgrel=1
+pkgdesc="ANSI C library that talks to CouchDB using libcurl and yajl"
+arch=('any')
+url="https://github.com/mgmarino/pillowtalk"
+license=('MIT')
+depends=('curl' 'yajl')
+makedepends=('git' 'cmake')
+source=("$pkgname"::"git+https://github.com/mgmarino/pillowtalk.git")
+md5sums=('SKIP')
+options=('strip')
+
+pkgver() {
+ cd $srcdir/$pkgname
+
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $srcdir/$pkgname
+ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr .
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname
+
+ make DESTDIR="$pkgdir/" install
+}