summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
2 files changed, 31 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90b27b350f8d..ef2100861aad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,25 @@
+# Generated by mksrcinfo v8
+# Fri Nov 4 17:45:09 UTC 2016
pkgbase = pingtcp
pkgdesc = Small utility to measure TCP handshake time (torify-friendly)
- pkgver = 0.0.2
- pkgrel = 2
- url = https://github.com/LanetNetwork/pingtcp
+ pkgver = 0.0.4
+ pkgrel = 1
+ url = https://github.com/pfactum/pingtcp
arch = i686
arch = x86_64
license = GPLv3
+ makedepends = gcc
makedepends = cmake
- makedepends = git
makedepends = make
+ makedepends = libunwind
+ makedepends = gperftools
depends = glibc
depends = gcc-libs
- optdepends = gperftools: for libtcmalloc
+ depends = libunwind
+ depends = gperftools
optdepends = torsocks: for TOR support
- source = pingtcp::git+https://github.com/LanetNetwork/pingtcp.git
- md5sums = SKIP
+ source = pingtcp-0.0.4.tar.gz::https://github.com/pfactum/pingtcp/archive/v0.0.4.tar.gz
+ sha256sums = ba6f3eb2660f703394bd0d40271a71f4d03434c89d71ae92ba2a2dcb50fd6ea6
pkgname = pingtcp
diff --git a/PKGBUILD b/PKGBUILD
index 196464a32934..5653e05e6a18 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,34 @@
# Maintainer: Oleksandr Natalenko aka post-factum <oleksandr@natalenko.name>
pkgname=pingtcp
-pkgver=0.0.2
-pkgrel=2
+pkgver=0.0.4
+pkgrel=1
pkgdesc="Small utility to measure TCP handshake time (torify-friendly)"
-url="https://github.com/LanetNetwork/pingtcp"
+url="https://github.com/pfactum/${pkgname}"
arch=('i686' 'x86_64')
license=('GPLv3')
-depends=('glibc' 'gcc-libs')
-optdepends=('gperftools: for libtcmalloc' 'torsocks: for TOR support')
-makedepends=('cmake' 'git' 'make')
-source=(${pkgname}::git+https://github.com/LanetNetwork/pingtcp.git)
+depends=('glibc' 'gcc-libs' 'libunwind' 'gperftools')
+optdepends=('torsocks: for TOR support')
+makedepends=('gcc' 'cmake' 'make' 'libunwind' 'gperftools')
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/pfactum/${pkgname}/archive/v${pkgver}.tar.gz)
-md5sums=('SKIP')
+sha256sums=('ba6f3eb2660f703394bd0d40271a71f4d03434c89d71ae92ba2a2dcb50fd6ea6')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
-build() {
- cd ${srcdir}/${pkgname}
- git submodule init
- git submodule update
mkdir -p build
- cd build
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
+
cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr ..
- # Detect CPUs count automatically
- CPUS_COUNT=$(nproc)
- echo "Compiling using $CPUS_COUNT thread(s)"
- make -j$CPUS_COUNT
+ make -j$(nproc)
}
package() {
- cd ${srcdir}/${pkgname}/build
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
+
make install
}