summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD9
3 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index acfa3d9ba08a..ff6d7a2606e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pioneer
pkgdesc = A game of lonely space adventure
pkgver = 20230203
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/pioneerspacesim/pioneer
arch = x86_64
license = GPL3
diff --git a/.gitignore b/.gitignore
index bd0a477689d3..976f890d0ea7 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,4 @@
*~
*.log
-pioneer-*.tar.gz
-pioneer-*.pkg.tar.zst
-pioneer-*.pkg.tar.xz
+pioneer-*.tar.*
+fix_path_to_lua_h.patch
diff --git a/PKGBUILD b/PKGBUILD
index 425133720c60..05fa590c2d87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=pioneer
pkgver=20230203
-pkgrel=1
+pkgrel=2
pkgdesc="A game of lonely space adventure"
arch=('x86_64')
url="https://github.com/pioneerspacesim/pioneer"
@@ -29,8 +29,11 @@ sha256sums=('80eea94e0f7e4d8e6a0c4629bdfb89201f82aae2f59ee7a1f7a487eeeccf27c7'
'dbb08eccb356c7b00122487b7a49df4948b82256c52b9cc36c5122a057c0635e')
prepare() {
- cd "$pkgname-$pkgver"
- patch -p1 -i "$srcdir/fix_path_to_lua_h.patch" # https://github.com/pioneerspacesim/pioneer/issues/5525
+ cd "$pkgname-$pkgver"
+ # fix version string, don't use the build date
+ sed -i 's|PROJECT_VERSION "%Y%m%d"|PROJECT_VERSION "'$pkgver'"|' CMakeLists.txt
+ # https://github.com/pioneerspacesim/pioneer/issues/5525
+ patch -p1 -i "$srcdir/fix_path_to_lua_h.patch"
}
build()