summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--LICENSE.txt10
-rw-r--r--PKGBUILD27
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0623032273dd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = pip2-tools
+ pkgdesc = A set of tools to keep your pinned Python dependencies fresh.
+ pkgver = 1.9.0
+ pkgrel = 1
+ url = https://github.com/jazzband/pip-tools/
+ arch = any
+ license = BSD
+ depends = python2-click
+ depends = python2-first
+ depends = python2-pip
+ depends = python2-six
+ source = https://pypi.io/packages/source/p/pip-tools/pip-tools-1.9.0.tar.gz
+ source = LICENSE.txt
+ md5sums = 28401a367a9a9c37cac56f76cf7f91d9
+ md5sums = b542fe20de254615b3ab48020bc73441
+
+pkgname = pip2-tools
+
diff --git a/LICENSE.txt b/LICENSE.txt
new file mode 100644
index 000000000000..e021942ceafb
--- /dev/null
+++ b/LICENSE.txt
@@ -0,0 +1,10 @@
+Copyright (c) 2015, Vincent Driessen <me@nvie.com>
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
+
+1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
+
+2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dfe21800ea27
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Cedric Girard <girard.cedric@gmail.com>
+# Contributor: Christopher Arndt <aur -at- chrisarndt -dot- de>
+# Contributor: Simon Conseil <contact+aur at saimon dot org>
+
+pkgname=pip2-tools
+_pythonmod=pip-tools
+pkgver=1.9.0
+pkgrel=1
+pkgdesc="A set of tools to keep your pinned Python dependencies fresh."
+arch=('any')
+url="https://github.com/jazzband/pip-tools/"
+license=('BSD')
+depends=('python2-click' 'python2-first' 'python2-pip' 'python2-six')
+source=("https://pypi.io/packages/source/${_pythonmod:0:1}/${_pythonmod}/${_pythonmod}-$pkgver.tar.gz"
+ LICENSE.txt)
+md5sums=('28401a367a9a9c37cac56f76cf7f91d9'
+ 'b542fe20de254615b3ab48020bc73441')
+
+package() {
+ cd ${srcdir}/${_pythonmod}-$pkgver
+
+ python2 setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1
+ install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
+ install -Dm644 "${srcdir}/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname"
+}
+
+# vim:set ts=2 sw=2 et: