summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5e3a8ac4c05..c63e7c1afe12 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = pip2pkgbuild
pkgdesc = Generate PKGBUILD file for a Python module from PyPI
- pkgver = 0.3.3
- pkgrel = 2
+ pkgver = 0.3.4
+ pkgrel = 1
url = https://github.com/wenLiangcan/pip2pkgbuild
arch = any
license = MIT
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
depends = python
- source = https://files.pythonhosted.org/packages/source/p/pip2pkgbuild/pip2pkgbuild-0.3.3.tar.gz
- sha256sums = 90172b48a10a2e416a7844e38892fa9b592af1cabc766938804f91fe62be8fc2
+ source = https://files.pythonhosted.org/packages/source/p/pip2pkgbuild/pip2pkgbuild-0.3.4.tar.gz
+ sha256sums = 8ba9de892d30259fe53073bb285f1562926e76d6d7866494f3160400ec2ebe52
pkgname = pip2pkgbuild
depends = python
diff --git a/PKGBUILD b/PKGBUILD
index a6951b98d706..0b46e9e175fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
pkgname='pip2pkgbuild'
_module='pip2pkgbuild'
-pkgver='0.3.3'
-pkgrel=2
+pkgver='0.3.4'
+pkgrel=1
pkgdesc="Generate PKGBUILD file for a Python module from PyPI"
url="https://github.com/wenLiangcan/pip2pkgbuild"
depends=('python')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer')
license=('MIT')
arch=('any')
source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/${_module/-/_}-$pkgver.tar.gz")
-sha256sums=('90172b48a10a2e416a7844e38892fa9b592af1cabc766938804f91fe62be8fc2')
+sha256sums=('8ba9de892d30259fe53073bb285f1562926e76d6d7866494f3160400ec2ebe52')
build() {
cd "${srcdir}/${_module}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
depends+=()
cd "${srcdir}/${_module}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}