summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD31
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..631e7317478f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pipecontrol
+ pkgdesc = Pipewire control GUI program in Qt
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/portaloffreedom/PipeControl
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ license = GPL3
+ makedepends = cmake
+ depends = pipewire>=0.3.38
+ depends = kirigami2
+ depends = kcoreaddons
+ source = PipeControl-0.2.0.tar.gz::https://github.com/portaloffreedom/PipeControl/archive/v0.2.0.tar.gz
+ sha256sums = b8db11c4a5e5ca6da0416127e5dc4e5d39bf18800ef03232e51b913e6c4f8d37
+
+pkgname = pipecontrol
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ad555f841116
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+/src/
+/pkg/
+
+PipeControl*.tar.gz
+*.pkg.tar.zst
+*.pkg.tar.zst.sig
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5aa6c6d86d92
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Matteo De Carlo <matteo dot dek at gmail dot com>
+
+pkgname=pipecontrol
+_pkgname=PipeControl
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="Pipewire control GUI program in Qt"
+arch=('i686' 'x86_64' 'aarch64')
+url="https://github.com/portaloffreedom/${_pkgname}"
+license=('GPL3')
+makedepends=('cmake')
+depends=('pipewire>=0.3.38' 'kirigami2' 'kcoreaddons')
+source=("$_pkgname-$pkgver.tar.gz::https://github.com/portaloffreedom/$_pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('b8db11c4a5e5ca6da0416127e5dc4e5d39bf18800ef03232e51b913e6c4f8d37')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc \
+ -DCMAKE_INSTALL_LIBEXECDIR="lib/${pkgname}" \
+ -DCMAKE_BUILD_TYPE=Release \
+ .
+
+ make all
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ DESTDIR="${pkgdir}" make install
+}
+