summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD24
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..41a36321757b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = pipr-bin
+ pkgdesc = A commandline-utility to interactively build complex shell pipelines
+ pkgver = 0.0.11
+ pkgrel = 1
+ url = https://gitlab.com/Elkowar/pipr
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = MIT
+ optdepends = bubblewrap: run commands in isolation. STRONGLY RECOMMENDED!
+ source = pipr::https://gitlab.com/Elkowar/pipr/uploads/9a4eb309170edb8880d550187e87a8a9/pipr
+ source = pipr-git::git+https://gitlab.com/Elkowar/pipr.git
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = pipr-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05371ffa1dd4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Leon Kowarschick <lkowarschick at gmail dot com>
+pkgname=pipr-bin
+pkgver=0.0.11
+pkgrel=1
+makedepends=()
+#depends=('gcc-libs')
+depends=()
+optdepends=('bubblewrap: run commands in isolation. STRONGLY RECOMMENDED!')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+pkgdesc="A commandline-utility to interactively build complex shell pipelines"
+license=('MIT')
+source=('pipr::https://gitlab.com/Elkowar/pipr/uploads/9a4eb309170edb8880d550187e87a8a9/pipr'
+ 'pipr-git::git+https://gitlab.com/Elkowar/pipr.git')
+url="https://gitlab.com/Elkowar/pipr"
+md5sums=('SKIP'
+ 'SKIP')
+
+
+package() {
+ cd "$srcdir"
+ install -Dm 755 pipr -t "${pkgdir}/usr/bin"
+ cd "$srcdir/pipr-git"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}