summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5865bf859886..3a96b345292f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pistache-git
pkgdesc = Modern and elegant HTTP and REST framework for C++
- pkgver = 985.c5927e1
+ pkgver = 1030.399d04e
pkgrel = 1
url = https://github.com/oktal/pistache
arch = i686
@@ -11,6 +11,7 @@ pkgbase = pistache-git
makedepends = git
provides = pistache
conflicts = pistache
+ options = staticlibs
source = pistache::git://github.com/oktal/pistache.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 040632dac271..de43092c5628 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=pistache-git
_name=${pkgname%-git}
-pkgver=985.c5927e1
+pkgver=1030.399d04e
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc='Modern and elegant HTTP and REST framework for C++'
@@ -15,6 +15,7 @@ makedepends=('cmake' 'git')
checkdepends=('gtest')
provides=("${_name}")
conflicts=("${_name}")
+options=(staticlibs)
url="https://github.com/oktal/${_name}"
source=("${_name}::git://github.com/oktal/${_name}.git")
sha256sums=('SKIP')
@@ -29,8 +30,10 @@ build() {
cmake \
-DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
-DPISTACHE_BUILD_TESTS=true \
- -DCMAKE_INSTALL_PREFIX="/usr"
+ -DPISTACHE_USE_SSL=true \
+ .
make
}