summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD25
2 files changed, 21 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 502c9fec766d..3c7a6fb4848f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,33 +1,31 @@
pkgbase = pithos
pkgdesc = Native Pandora Radio client
- pkgver = 1.4.0
+ pkgver = 1.6.2
pkgrel = 1
url = https://pithos.github.io/
arch = any
- license = GPL3
+ license = GPL-3.0-only
makedepends = meson
makedepends = appstream-glib
depends = gtk3
depends = python-gobject
depends = libsecret
depends = python-cairo
+ depends = pango
+ depends = python
+ depends = dconf
+ depends = gdk-pixbuf2
+ depends = hicolor-icon-theme
depends = gst-plugins-good
depends = gst-libav
depends = gst-plugins-base
optdepends = libkeybinder3: for media keys plugin
- optdepends = libappindicator-gtk3: Unity indicator applet support
optdepends = python-pacparser: PAC proxy support
optdepends = python-pylast: Last.fm scrobbling support
optdepends = python-systemd: Logging to the system journal
- source = https://github.com/pithos/pithos/releases/download/1.4.0/pithos-1.4.0.tar.xz
- source = https://github.com/pithos/pithos/releases/download/1.4.0/pithos-1.4.0.tar.xz.asc
- source = dbus.service
+ source = pithos-1.6.2.tar.gz::https://github.com/pithos/pithos/archive/refs/tags/1.6.2.tar.gz
source = systemd.service
- validpgpkeys = 108BF2212A051F4A72B18448B3C7CE210DE76DFC
- sha256sums = 4c025d7e1e055292849b80c37d8ad3862e0f2cbd9c7327664deb8ac0389952ac
- sha256sums = SKIP
- sha256sums = 2b80c9bb84f7de8de0e36dc16465c6633cb74de7bf777efcad76393e88a6e62a
+ sha256sums = 69fffb5af07787eaf603d9e63b6facf25cc41760109dee5a92514354edd1068d
sha256sums = 6d29178697384fb046d9d25c6c2482f353a4484ec4f0a5b9080d1a26aa24f839
pkgname = pithos
-
diff --git a/PKGBUILD b/PKGBUILD
index 20bfdf573b38..b89724934020 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,34 @@
# Contributor: Matthew Bauer <mjbauer95@gmail.com>
# Contributor: TingPing <tingping@fedoraproject.org>
# Contributor: Christopher Eby <kreed@kreed.org>
-# Maintainer: Steven Allen <steven@stebalien.com>
+# Contributor: Steven Allen <steven@stebalien.com>
pkgname=pithos
-pkgver=1.4.0
+pkgver=1.6.2
pkgrel=1
pkgdesc='Native Pandora Radio client'
-arch=('any')
+arch=(any)
url="https://pithos.github.io/"
-license=('GPL3')
-depends=('gtk3' 'python-gobject' 'libsecret' 'python-cairo'
+license=(GPL-3.0-only)
+depends=('gtk3' 'python-gobject' 'libsecret' 'python-cairo' 'pango'
+ 'python' 'dconf' 'gdk-pixbuf2' 'hicolor-icon-theme'
'gst-plugins-good' 'gst-libav' 'gst-plugins-base')
optdepends=('libkeybinder3: for media keys plugin'
- 'libappindicator-gtk3: Unity indicator applet support'
'python-pacparser: PAC proxy support'
'python-pylast: Last.fm scrobbling support'
'python-systemd: Logging to the system journal')
makedepends=('meson' 'appstream-glib')
source=(
- "https://github.com/pithos/pithos/releases/download/${pkgver}/pithos-${pkgver}.tar.xz"{,.asc}
- "dbus.service"
+ "pithos-${pkgver}.tar.gz::https://github.com/pithos/pithos/archive/refs/tags/${pkgver}.tar.gz"
"systemd.service"
)
-sha256sums=('4c025d7e1e055292849b80c37d8ad3862e0f2cbd9c7327664deb8ac0389952ac'
- 'SKIP'
- '2b80c9bb84f7de8de0e36dc16465c6633cb74de7bf777efcad76393e88a6e62a'
+sha256sums=('69fffb5af07787eaf603d9e63b6facf25cc41760109dee5a92514354edd1068d'
'6d29178697384fb046d9d25c6c2482f353a4484ec4f0a5b9080d1a26aa24f839')
-validpgpkeys=('108BF2212A051F4A72B18448B3C7CE210DE76DFC')
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ echo "SystemdService=pithos.service" >> "data/io.github.Pithos.service.in"
+}
build() {
cd "${srcdir}"
@@ -42,6 +42,5 @@ build() {
package() {
cd "${srcdir}/build"
DESTDIR="${pkgdir}" ninja install
- install -Dm644 "${srcdir}/dbus.service" "${pkgdir}/usr/share/dbus-1/services/io.github.Pithos.service"
install -Dm644 "${srcdir}/systemd.service" "${pkgdir}/usr/lib/systemd/user/pithos.service"
}