summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD41
-rw-r--r--pithos-git.install12
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de5b089eeb53
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = pithos-git
+ pkgdesc = Pandora Internet Radio player for GNOME
+ pkgver = 451
+ pkgrel = 1
+ epoch = 1
+ url = http://pithos.github.io/
+ install = pithos-git.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python
+ depends = gtk3
+ depends = python-gobject
+ depends = gst-plugins-good
+ depends = gst-plugins-bad
+ depends = gst-plugins-base
+ depends = python-setuptools
+ depends = python-cairo
+ optdepends = libkeybinder3: for media keys plugin
+ optdepends = gst-plugins-ugly: MP3 playback support
+ optdepends = libappindicator-gtk3: Unity indicator applet support
+ optdepends = python-pacparser: PAC proxy support
+ optdepends = python-pylast: Last.fm scrobbling support
+ optdepends = libnotify: Notification support
+ optdepends = python-dbus: MPRIS/Screensaver Pause/Gnome mediakeys support
+ provides = pithos
+ conflicts = pithos-bzr
+ conflicts = pithos
+ source = pithos-git.install
+ source = git+https://github.com/pithos/pithos.git
+ sha256sums = 961b42a5b1105ff4625b86f87b5fa5d83a59495149cfb74b59f51e910a474ff9
+ sha256sums = SKIP
+
+pkgname = pithos-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..449a86e1d6cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Contributor: Matthew Bauer <mjbauer95@gmail.com>
+# Contributor: TingPing <tingping@fedoraproject.org>
+# Maintainer: Steven Allen <steven@stebalien.com>
+
+_pkgname=pithos
+pkgname=$_pkgname-git
+pkgver=451
+pkgrel=1
+epoch=1
+pkgdesc='Pandora Internet Radio player for GNOME'
+arch=('any')
+url="http://pithos.github.io/"
+license=('GPL3')
+depends=('python' 'gtk3' 'python-gobject'
+ 'gst-plugins-good' 'gst-plugins-bad' 'gst-plugins-base'
+ 'python-setuptools' 'python-cairo')
+optdepends=('libkeybinder3: for media keys plugin'
+ 'gst-plugins-ugly: MP3 playback support'
+ 'libappindicator-gtk3: Unity indicator applet support'
+ 'python-pacparser: PAC proxy support'
+ 'python-pylast: Last.fm scrobbling support'
+ 'libnotify: Notification support'
+ 'python-dbus: MPRIS/Screensaver Pause/Gnome mediakeys support')
+makedepends=('git')
+provides=("$_pkgname")
+conflicts=("$_pkgname-bzr" "$_pkgname")
+install="$pkgname.install"
+sha256sums=('961b42a5b1105ff4625b86f87b5fa5d83a59495149cfb74b59f51e910a474ff9'
+ 'SKIP')
+
+source=("$pkgname.install" "git+https://github.com/pithos/pithos.git")
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git rev-list HEAD --count
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ python setup.py install --optimize=1 --prefix=/usr --root="${pkgdir}/"
+}
diff --git a/pithos-git.install b/pithos-git.install
new file mode 100644
index 000000000000..db6d40bae922
--- /dev/null
+++ b/pithos-git.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}