summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD35
-rw-r--r--dkms.conf7
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a301104213c7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Tue May 31 15:55:42 UTC 2016
+pkgbase = piuio-dkms-git
+ pkgdesc = Kernel driver for the PIUIO arcade input device (with DKMS)
+ pkgver = 1.0.r0.gc270904
+ pkgrel = 1
+ url = https://github.com/djpohly/piuio
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = dkms
+ provides = piuio
+ conflicts = piuio
+ source = git+https://github.com/djpohly/piuio.git
+ source = dkms.conf
+ sha256sums = SKIP
+ sha256sums = 030ffe1732d95095df5e8db4316b0c4dbfa3566394ea56f6bd6d67d0665e804c
+
+pkgname = piuio-dkms-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18639db7c7e0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Devin J. Pohly <djpohly+arch@gmail.com>
+pkgname=piuio-dkms-git
+_pkgname=piuio
+pkgver=1.0.r0.gc270904
+pkgrel=1
+pkgdesc="Kernel driver for the PIUIO arcade input device (with DKMS)"
+arch=('i686' 'x86_64')
+url="https://github.com/djpohly/$_pkgname"
+license=('GPL2')
+makedepends=('git')
+depends=('dkms')
+provides=('piuio')
+conflicts=('piuio')
+source=("git+https://github.com/djpohly/$_pkgname.git" 'dkms.conf')
+sha256sums=('SKIP'
+ '030ffe1732d95095df5e8db4316b0c4dbfa3566394ea56f6bd6d67d0665e804c')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/$_pkgname/mod"
+
+ # Install and update DKMS config
+ install -Dm644 "$srcdir/dkms.conf" "$pkgdir/usr/src/$_pkgname-$pkgver/dkms.conf"
+ sed -i -e "s/@_PKGNAME@/$_pkgname/g" -e "s/@PKGVER@/$pkgver/g" \
+ "$pkgdir/usr/src/$_pkgname-$pkgver/dkms.conf"
+
+ # Install sources
+ install -m644 -t "$pkgdir/usr/src/$_pkgname-$pkgver/" Makefile piuio.c
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/dkms.conf b/dkms.conf
new file mode 100644
index 000000000000..c35b02a23e11
--- /dev/null
+++ b/dkms.conf
@@ -0,0 +1,7 @@
+PACKAGE_NAME="@_PKGNAME@"
+PACKAGE_VERSION="@PKGVER@"
+MAKE[0]="make KVER=$kernelver"
+CLEAN="make clean"
+BUILT_MODULE_NAME[0]="@_PKGNAME@"
+DEST_MODULE_LOCATION[0]="/kernel/drivers/misc"
+AUTOINSTALL="yes"