summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO33
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD40
-rw-r--r--com.orama_interactive.Pixelorama.appdata.xml38
-rw-r--r--com.orama_interactive.Pixelorama.desktop15
-rw-r--r--pixelorama.pngbin0 -> 455 bytes
6 files changed, 147 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c386aabf7af9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = pixelorama-bin
+ pkgdesc = A free & open-source 2D sprite editor, made with the Godot Engine - precompiled binary
+ pkgver = 0.7
+ pkgrel = 1
+ url = https://www.orama-interactive.com/pixelorama
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = libpulse
+ depends = alsa-lib
+ depends = libxrandr
+ depends = libglvnd
+ depends = libxcursor
+ depends = libxinerama
+ depends = hicolor-icon-theme
+ provides = pixelorama
+ conflicts = pixelorama
+ conflicts = pixelorama-git
+ source = pixelorama.png
+ source = com.orama_interactive.Pixelorama.appdata.xml
+ source = com.orama_interactive.Pixelorama.desktop
+ source = LICENSE
+ sha256sums = d92715606fb34e1863ecccd929675b742988ae55118146e2d9aee41c650b0933
+ sha256sums = 22098341228acc5940c72a741c2e04804d1373f7f89c282526cfa66adddd94e0
+ sha256sums = 5d9b6e1a44b07bfcfbf4fb3575d30df457571335c0c200f4130af51884f34b99
+ sha256sums = 71f1828c30422206232e07fb511aab07e2295845719b2d0705a881f27fb43949
+ source_i686 = https://github.com/Orama-Interactive/Pixelorama/releases/download/v0.7/Pixelorama.v0.7.Linux.32-bit.zip
+ sha256sums_i686 = 3a7ed5ae486335d3c4d2427e98b87fd5ef7d725b8d8383f10ba99d094e8a5f18
+ source_x86_64 = https://github.com/Orama-Interactive/Pixelorama/releases/download/v0.7/Pixelorama.v0.7.Linux.64-bit.zip
+ sha256sums_x86_64 = bd6bb866ac98ca3d0091bf78cc1617984732a3670a6c2b9859f2b12bf8648ea0
+
+pkgname = pixelorama-bin
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..2825d3556efe
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2019 OverloadedOrama
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf33acf3a58c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Hilton Medeiros <medeiros.hilton@gmail.com>
+_pkgname=Pixelorama
+pkgname=pixelorama-bin
+pkgver=0.7
+pkgrel=1
+pkgdesc="A free & open-source 2D sprite editor, made with the Godot Engine - precompiled binary"
+arch=('i686' 'x86_64')
+url="https://www.orama-interactive.com/pixelorama"
+license=('MIT')
+depends=('libpulse' 'alsa-lib' 'libxrandr' 'libglvnd' 'libxcursor' 'libxinerama' 'hicolor-icon-theme')
+provides=('pixelorama')
+conflicts=('pixelorama' 'pixelorama-git')
+source=("pixelorama.png" "com.orama_interactive.Pixelorama.appdata.xml" "com.orama_interactive.Pixelorama.desktop" "LICENSE")
+source_i686=("https://github.com/Orama-Interactive/$_pkgname/releases/download/v$pkgver/$_pkgname.v$pkgver.Linux.32-bit.zip")
+source_x86_64=("https://github.com/Orama-Interactive/$_pkgname/releases/download/v$pkgver/$_pkgname.v$pkgver.Linux.64-bit.zip")
+sha256sums=('d92715606fb34e1863ecccd929675b742988ae55118146e2d9aee41c650b0933'
+ '22098341228acc5940c72a741c2e04804d1373f7f89c282526cfa66adddd94e0'
+ '5d9b6e1a44b07bfcfbf4fb3575d30df457571335c0c200f4130af51884f34b99'
+ '71f1828c30422206232e07fb511aab07e2295845719b2d0705a881f27fb43949')
+sha256sums_i686=('3a7ed5ae486335d3c4d2427e98b87fd5ef7d725b8d8383f10ba99d094e8a5f18')
+sha256sums_x86_64=('bd6bb866ac98ca3d0091bf78cc1617984732a3670a6c2b9859f2b12bf8648ea0')
+
+package() {
+ install -d "$pkgdir/opt/$pkgname"
+ install -d "$pkgdir/usr/bin"
+ install -d "$pkgdir/usr/share/metainfo"
+ install -d "$pkgdir/usr/share/applications"
+ install -d "$pkgdir/usr/share/icons/hicolor/256x256/apps"
+
+ test "${CARCH}" == 'x86_64' && _pkgarch='64' || _pkgarch='32'
+ cp -Trf "$srcdir/$_pkgname v$pkgver [Linux $_pkgarch-bit]" "$pkgdir/opt/$pkgname"
+ install -Dm644 "$srcdir/com.orama_interactive.Pixelorama.desktop" "$pkgdir/usr/share/applications"
+ install -Dm644 "$srcdir/com.orama_interactive.Pixelorama.appdata.xml" "$pkgdir/usr/share/metainfo"
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "$srcdir/pixelorama.png" "$pkgdir/usr/share/icons/hicolor/256x256/apps"
+
+ chmod +x ${pkgdir}/opt/${pkgname}/{*.so,${_pkgname}.x86*}
+
+ ln -s /opt/${pkgname}/${_pkgname}.x86* "$pkgdir/usr/bin/pixelorama"
+}
diff --git a/com.orama_interactive.Pixelorama.appdata.xml b/com.orama_interactive.Pixelorama.appdata.xml
new file mode 100644
index 000000000000..dec61fc947be
--- /dev/null
+++ b/com.orama_interactive.Pixelorama.appdata.xml
@@ -0,0 +1,38 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!-- Copyright (c) 2019 Orama Interactive -->
+<component type="desktop">
+ <id>com.orama_interactive.Pixelorama.desktop</id>
+ <name>Pixelorama</name>
+ <summary>2D sprite editor with animation support</summary>
+ <description>
+ <p>
+ Pixelorama is a free and open source 2D sprite editor, made by Orama
+ Interactive in the Godot Engine using GDScript.
+ </p>
+ </description>
+ <metadata_license>CC0-1.0</metadata_license>
+ <project_license>MIT</project_license>
+ <developer_name>Orama Interactive</developer_name>
+ <url type="homepage">https://www.orama-interactive.com/pixelorama</url>
+ <url type="bugtracker">https://github.com/Orama-Interactive/Pixelorama/issues</url>
+ <screenshots>
+ <screenshot type="default" width="1919" height="1053">
+ <image type="source">https://static.wixstatic.com/media/673cdd_061f5f9602ea4c35b6d4f3c50713d36a~mv2.png</image>
+ <caption>Art by Wishdream</caption>
+ </screenshot>
+ <screenshot type="default" width="1919" height="1079">
+ <image type="source">https://static.wixstatic.com/media/cc6108_ccec89c37b3d425da4f03776160c859c~mv2.png</image>
+ <caption>Art by Erevos</caption>
+ </screenshot>
+ <screenshot type="default" width="1919" height="1079">
+ <image type="source">https://static.wixstatic.com/media/cc6108_854ca4dc022c481f96bbc2b4f03fb04d~mv2.png</image>
+ <caption>Art by Erevos</caption>
+ </screenshot>
+ </screenshots>
+ <content_rating type="oars-1.1"/>
+ <releases>
+ <release version="0.7" date="2020-05-16"/>
+ <release version="0.6.2" date="2020-02-17"/>
+ </releases>
+ <update_contact>hugo.locurcio@hugo.pro</update_contact>
+</component>
diff --git a/com.orama_interactive.Pixelorama.desktop b/com.orama_interactive.Pixelorama.desktop
new file mode 100644
index 000000000000..9d3123b371bd
--- /dev/null
+++ b/com.orama_interactive.Pixelorama.desktop
@@ -0,0 +1,15 @@
+[Desktop Entry]
+Name=Pixelorama
+GenericName=2D sprite editor
+GenericName[el]=Επεξεργαστής δισδιάστατων εικόνων
+GenericName[fr]=Éditeur de sprites 2D
+GenericName[pt_BR]=Editor de sprites 2D
+Comment=Create and edit static or animated 2D sprites
+Comment[el]=Δημιουργήστε και επεξεργαστείτε στατικές ή κινούμενες δισδιάστατες εικόνες
+Comment[fr]=Créez et modifiez des sprites 2D statiques ou animées
+Comment[pt_BR]=Crie e edite sprites 2D estáticos ou animados
+Exec=pixelorama
+Icon=pixelorama
+Terminal=false
+Type=Application
+Categories=Graphics;2DGraphics;RasterGraphics;
diff --git a/pixelorama.png b/pixelorama.png
new file mode 100644
index 000000000000..fe3b22841851
--- /dev/null
+++ b/pixelorama.png
Binary files differ