summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore18
-rw-r--r--PKGBUILD51
3 files changed, 49 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 18a121fceb88..a44800732600 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = pixiecore-git
pkgdesc = An all-in-one tool for easy netbooting
- pkgver = r306.870d490
- pkgrel = 1
- url = https://github.com/google/netboot
- arch = x86_64
- arch = armv7h
- license = GPL2
+ pkgver = r353.64f6de6
+ pkgrel = 2
+ url = https://godoc.org/go.universe.tf/netboot/pixiecore
+ arch = any
+ license = Apache
makedepends = git
makedepends = go
- depends = glibc
+ makedepends = gcc
+ makedepends = binutils
provides = pixiecore
conflicts = pixiecore
+ source = pixiecore::git+https://github.com/danderson/netboot.git
+ sha512sums = SKIP
pkgname = pixiecore-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e16177da2907
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,18 @@
+*/
+.*.swp
+*.pkg.tar.xz
+src/
+pkg/
+*.tar
+*.tar.bz2
+*.tar.xz
+*.tar.gz
+*.tgz
+*.txz
+*.tbz
+*.tbz2
+*.zip
+*.run
+*.7z
+*.rar
+*.deb
diff --git a/PKGBUILD b/PKGBUILD
index 101dcca03c84..09f3c909a643 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,34 @@
-# Maintainer: zargbell <zargbell@yandex.ru>
+# Maintainer: Nara Díaz Viñolas <rdvdev2@gmail.com>
+
pkgname=pixiecore-git
-pkgver=r306.870d490
-pkgrel=1
+_pkgname='pixiecore'
+pkgver=r353.64f6de6
+pkgrel=2
pkgdesc="An all-in-one tool for easy netbooting"
-arch=("x86_64" "armv7h")
-url="https://github.com/google/netboot"
-license=("GPL2")
-depends=("glibc")
-makedepends=("git" "go")
-optdepends=()
+arch=('any')
+url="https://godoc.org/go.universe.tf/netboot/pixiecore"
+license=('Apache')
+makedepends=('git' 'go' 'gcc' 'binutils')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-replaces=()
-options=()
-
-
-prepare() {
- export GOPATH="$srcdir/go"
- mkdir -p $GOPATH
-
- export GOBIN="$GOPATH/bin"
- mkdir -p $GOBIN
+source=("${_pkgname}::git+https://github.com/danderson/netboot.git")
+sha512sums=('SKIP')
- go env
-
- go get -d -v go.universe.tf/netboot/cmd/pixiecore
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-pkgver(){
- cd "${GOPATH}/src/go.universe.tf/netboot/"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
+# https://wiki.archlinux.org/index.php/Go_package_guidelines
build() {
- go install -v go.universe.tf/netboot/cmd/pixiecore
+ cd "${srcdir}/${_pkgname}"
+ go build \
+ -o ${_pkgname} \
+ ${srcdir}/${_pkgname}/cmd/pixiecore
}
package() {
- install -Dm755 "$GOBIN/${pkgname%-git}" "${pkgdir}/usr/bin/${pkgname%-git}"
-} \ No newline at end of file
+ cd ${srcdir}/${_pkgname}/${_pkgname}
+ install -Dm755 ${_pkgname} "${pkgdir}/usr/bin/${_pkgname}"
+}