summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD6
3 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index acec0e6649b9..afc04e80ecef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = pkg2zip
pkgdesc = Decrypts PlayStation Vita pkg file and packages to zip archive
- pkgver = 1.6
+ pkgver = 1.8
pkgrel = 1
url = https://github.com/mmozeiko/pkg2zip
arch = i686
arch = x86_64
license = custom:unlicense
- source = https://github.com/mmozeiko/pkg2zip/archive/v1.6.tar.gz
- sha256sums = 3243513ddd96a1086fabcf7e347a3ee8f1014a0963262a68616dd48cc0a69065
+ source = https://github.com/mmozeiko/pkg2zip/archive/v1.8.tar.gz
+ sha256sums = 4290b37a41ab4c0044aebd90fbea973bd5950ed1fdb0c06011067c4be9103f3a
pkgname = pkg2zip
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..80aec82786b2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+*.tar.gz
+*.tar
diff --git a/PKGBUILD b/PKGBUILD
index b77557410bc6..49a021e82c55 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Martins Mozeiko <martins.mozeiko@gmail.com>
pkgname=pkg2zip
-pkgver=1.6
+pkgver=1.8
pkgrel=1
pkgdesc='Decrypts PlayStation Vita pkg file and packages to zip archive'
url='https://github.com/mmozeiko/pkg2zip'
arch=('i686' 'x86_64')
license=('custom:unlicense')
source=("https://github.com/mmozeiko/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('3243513ddd96a1086fabcf7e347a3ee8f1014a0963262a68616dd48cc0a69065')
+sha256sums=('4290b37a41ab4c0044aebd90fbea973bd5950ed1fdb0c06011067c4be9103f3a')
package() {
cd "${srcdir}"/"${pkgname}-${pkgver}"
- make
+ make CFLAGS="-DNDEBUG -O2 -Wno-format-truncation"
install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
install -Dm755 pkg2zip "${pkgdir}"/usr/bin/pkg2zip