summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore6
-rw-r--r--0001-Fix-build-failure-missing-include-of-optional.patch32
-rw-r--r--PKGBUILD56
4 files changed, 81 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45bcd607bf68..55906d4cc600 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,29 @@
pkgbase = pkgfile-git
pkgdesc = a pacman .files metadata explorer
- pkgver = 21
+ pkgver = 21.r52.9c45690
pkgrel = 1
- url = http://github.com/falconindy/pkgfile
+ epoch = 1
+ url = https://github.com/falconindy/pkgfile
install = pkgfile.install
arch = x86_64
arch = i686
license = MIT
- checkdepends = python
- checkdepends = gtest
checkdepends = gmock
+ checkdepends = gtest
+ checkdepends = python
makedepends = git
- makedepends = perl
makedepends = meson
- depends = libarchive
+ makedepends = perl
depends = curl
- depends = pcre
+ depends = libarchive
depends = pacman
+ depends = pcre
+ depends = systemd-libs
provides = pkgfile
conflicts = pkgfile
- source = git+https://github.com/falconindy/pkgfile
- md5sums = SKIP
+ source = git+https://github.com/falconindy/pkgfile.git
+ source = 0001-Fix-build-failure-missing-include-of-optional.patch
+ b2sums = SKIP
+ b2sums = eb2bc196cbd1c084ed81c4664bbffa2c57f5aa743a9928347003ed062479bb78cc9bfed6fd9346067f0e2fae062d9707f90662a70a93d6d6b9706380339c2f75
pkgname = pkgfile-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fadb16b18b37
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!0001-Fix-build-failure-missing-include-of-optional.patch
+!pkgfile.install
diff --git a/0001-Fix-build-failure-missing-include-of-optional.patch b/0001-Fix-build-failure-missing-include-of-optional.patch
new file mode 100644
index 000000000000..155e39ddec1e
--- /dev/null
+++ b/0001-Fix-build-failure-missing-include-of-optional.patch
@@ -0,0 +1,32 @@
+From ebd4011c0f931935ed592f0ffe64364e4deb05f8 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?=C5=A0t=C4=9Bp=C3=A1n=20N=C4=9Bmec?= <stepnem@gmail.com>
+Date: Thu, 18 Aug 2022 12:07:44 +0200
+Subject: [PATCH] Fix build failure (missing include of <optional>)
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+E.g.:
+../src/pkgfile.hh:76:8: error: ‘optional’ in namespace ‘std’ does not name a template type
+ 76 | std::optional<pkgfile::Result> ProcessRepo(const std::filesystem::path repo,
+ | ^~~~~~~~
+../src/pkgfile.hh:9:1: note: ‘std::optional’ is defined in header ‘<optional>’; did you forget to ‘#include <optional>’?
+---
+ src/pkgfile.hh | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/pkgfile.hh b/src/pkgfile.hh
+index 8ef6781..23d6f9a 100644
+--- a/src/pkgfile.hh
++++ b/src/pkgfile.hh
+@@ -2,6 +2,7 @@
+
+ #include <filesystem>
+ #include <map>
++#include <optional>
+
+ #include "archive_reader.hh"
+ #include "filter.hh"
+--
+2.39.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 43163b669f19..2ae801cc685d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,48 @@
-# Contributor: Dave Reisner <d@falconindy.com>
+# Maintainer: éclairevoyant
+# Contributor: Dave Reisner <d at falconindy dot com>
-pkgname=pkgfile-git
-pkgver=21
+_pkgname=pkgfile
+pkgname="$_pkgname-git"
+pkgver=21.r52.9c45690
pkgrel=1
+epoch=1
pkgdesc="a pacman .files metadata explorer"
arch=('x86_64' 'i686')
-url="http://github.com/falconindy/pkgfile"
+url="https://github.com/falconindy/$_pkgname"
license=('MIT')
-depends=('libarchive' 'curl' 'pcre' 'pacman')
-makedepends=('git' 'perl' 'meson')
-checkdepends=('python' 'gtest' 'gmock')
-conflicts=('pkgfile')
-provides=('pkgfile')
-install=pkgfile.install
-source=("git+https://github.com/falconindy/pkgfile")
-md5sums=('SKIP')
+depends=(curl libarchive pacman pcre systemd-libs)
+makedepends=(git meson perl)
+checkdepends=(gmock gtest python)
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+install="$_pkgname.install"
+source=("git+$url.git"
+ 0001-Fix-build-failure-missing-include-of-optional.patch)
+b2sums=('SKIP'
+ 'eb2bc196cbd1c084ed81c4664bbffa2c57f5aa743a9928347003ed062479bb78cc9bfed6fd9346067f0e2fae062d9707f90662a70a93d6d6b9706380339c2f75')
pkgver() {
- cd pkgfile
+ cd $_pkgname
+ git describe | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'
+}
- git describe | sed 's/^v//;s/-/./g'
+prepare() {
+ cd $_pkgname
+ patch -Np1 -i ../0001-Fix-build-failure-missing-include-of-optional.patch
}
build() {
- cd pkgfile
-
- arch-meson build
- ninja -C build
+ cd $_pkgname
+ arch-meson build
+ ninja -C build
}
check() {
- cd pkgfile
-
- meson test -C build
+ cd $_pkgname
+ meson test -C build
}
package() {
- cd pkgfile
-
- DESTDIR="$pkgdir" ninja -C build install
+ cd $_pkgname
+ DESTDIR="$pkgdir" ninja -C build install
}
-
-# vim: ft=sh syn=sh et