summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD28
-rw-r--r--pkgfile.install2
3 files changed, 22 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 836857dcc43f..e63a977ae29e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,22 @@
pkgbase = pkgfile-git
pkgdesc = a pacman .files metadata explorer
- pkgver = 15.7.g7ace342
+ pkgver = 18
pkgrel = 1
url = http://github.com/falconindy/pkgfile
install = pkgfile.install
- arch = i686
arch = x86_64
+ arch = i686
license = MIT
makedepends = git
makedepends = perl
+ makedepends = meson
depends = libarchive
depends = curl
depends = pcre
depends = pacman
provides = pkgfile
- provides = nosr
conflicts = pkgfile
- conflicts = nosr
- replaces = nosr-git
- source = git://github.com/falconindy/pkgfile
+ source = git+https://github.com/falconindy/pkgfile
md5sums = SKIP
pkgname = pkgfile-git
diff --git a/PKGBUILD b/PKGBUILD
index 8ba19417d753..11f4ced1ce95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,42 @@
# Contributor: Dave Reisner <d@falconindy.com>
pkgname=pkgfile-git
-pkgver=15.7.g7ace342
+pkgver=18
pkgrel=1
pkgdesc="a pacman .files metadata explorer"
-arch=('i686' 'x86_64')
+arch=('x86_64' 'i686')
url="http://github.com/falconindy/pkgfile"
license=('MIT')
depends=('libarchive' 'curl' 'pcre' 'pacman')
-makedepends=('git' 'perl')
-conflicts=('pkgfile' 'nosr')
-provides=('pkgfile' 'nosr')
-replaces=('nosr-git')
+makedepends=('git' 'perl' 'meson')
+conflicts=('pkgfile')
+provides=('pkgfile')
install=pkgfile.install
-source=("git://github.com/falconindy/pkgfile")
+source=("git+https://github.com/falconindy/pkgfile")
md5sums=('SKIP')
pkgver() {
cd pkgfile
+
git describe | sed 's/^v//;s/-/./g'
}
+prepare() {
+ cd pkgfile
+
+ meson build -D buildtype=release
+}
+
build() {
cd pkgfile
- ./autogen.sh
- ./configure
- make
+ ninja -C build
}
package() {
- make -C pkgfile DESTDIR="$pkgdir" install
+ cd pkgfile
+
+ DESTDIR="$pkgdir" ninja -C build install
}
# vim: ft=sh syn=sh et
diff --git a/pkgfile.install b/pkgfile.install
index bf0c9cfa355c..d57489a49c79 100644
--- a/pkgfile.install
+++ b/pkgfile.install
@@ -6,7 +6,7 @@ post_install() {
post_remove() {
# the cache dir might not be removed, notify the user
- if [ -d var/cache/pkgfile ]; then
+ if [[ -d var/cache/pkgfile ]]; then
printf "==> /var/cache/pkgfile has not been removed\n"
fi
}