summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD19
3 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f74618a4cc39
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = pkglog
+ pkgdesc = Reports log of package updates
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/bulletmark/pkglog
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python>=3.7
+ source = pkglog-1.0.tar.gz::https://github.com/bulletmark/pkglog/archive/1.0.tar.gz
+ sha1sums = 9b2cadda37354b6fffde307502adb29006560262
+
+pkgname = pkglog
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6dd39bbd03b8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.tar
+*.[gx]z
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a5270e7f104
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: mark.blakeney at bullet-systems dot net
+pkgname=pkglog
+pkgver=1.0
+pkgrel=1
+pkgdesc="Reports log of package updates"
+url="https://github.com/bulletmark/$pkgname"
+license=("GPL3")
+arch=("any")
+depends=("python>=3.7")
+makedepends=("python-setuptools")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha1sums=('9b2cadda37354b6fffde307502adb29006560262')
+
+package() {
+ cd "$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: