summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD42
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db34aca7f278
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+# Generated by mksrcinfo v8
+# Tue Mar 27 15:16:19 UTC 2018
+pkgbase = plank-git
+ pkgdesc = Elegant, simple, clean dock
+ pkgver = 0.11.4.r19.42cb5e3
+ pkgrel = 1
+ url = https://launchpad.net/plank
+ arch = x86_64
+ license = GPL3
+ makedepends = gnome-common
+ makedepends = git
+ makedepends = intltool
+ makedepends = vala
+ depends = atk
+ depends = bamf
+ depends = cairo
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = glibc
+ depends = gnome-menus
+ depends = gtk3
+ depends = libgee
+ depends = libwnck3
+ depends = libx11
+ depends = libxfixes
+ depends = libxi
+ depends = pango
+ provides = plank
+ conflicts = plank
+ source = git+https://github.com/ricotz/plank.git
+ sha256sums = SKIP
+
+pkgname = plank-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c083c4427f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Ner0 <darkelfdarkelf666@yahoo.co.uk>
+# Contributor: dcelasun <dcelasun@gmail.com>
+
+pkgname=plank-git
+pkgver=0.11.4.r19.42cb5e3
+pkgrel=1
+pkgdesc='Elegant, simple, clean dock'
+arch=('x86_64')
+url='https://launchpad.net/plank'
+license=('GPL3')
+depends=('atk' 'bamf' 'cairo' 'gdk-pixbuf2' 'glib2' 'glibc' 'gnome-menus'
+ 'gtk3' 'libgee' 'libwnck3' 'libx11' 'libxfixes' 'libxi' 'pango')
+makedepends=('gnome-common' 'git' 'intltool' 'vala')
+provides=('plank')
+conflicts=('plank')
+source=('git+https://github.com/ricotz/plank.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd plank
+
+ echo "$(git describe --tags | sed 's/^v//; s/-/.r/; s/-g/./')"
+}
+
+build() {
+ cd plank
+
+ ./autogen.sh \
+ --prefix='/usr' \
+ --sysconfdir='/etc' \
+ --disable-apport
+ make
+}
+
+package() {
+ cd plank
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: