summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD23
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ec8652e9e7ee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = plasma-dialer-git
+ pkgdesc = Dialer for Plasma Mobile
+ pkgver = 21.06
+ pkgrel = 1
+ url = https://invent.kde.org/plasma-mobile/plasma-dialer
+ arch = x86_64
+ arch = arm
+ arch = armv7h
+ arch = armv6h
+ arch = aarch64
+ license = GPL2
+ makedepends = extra-cmake-modules
+ makedepends = qt5-svg
+ makedepends = qt5-tools
+ depends = kcontacts
+ depends = kirigami2
+ depends = ki18n
+ depends = kconfig
+ depends = kpeople
+ depends = kcoreaddons
+ depends = kdbusaddons
+ depends = knotifications
+ depends = libqofono-git
+ depends = telepathy-qt
+ depends = libpulse
+ depends = libphonenumber
+ source = https://download.kde.org/stable/plasma-mobile/21.06/plasma-dialer-git-21.06.tar.xz
+ sha256sums = SKIP
+
+pkgname = plasma-dialer-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4ad534e8dbdf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer Gustavo Castro < gustawho [ at ] gmail [ dot ] com >
+
+pkgname=plasma-dialer-git
+pkgver=21.06
+pkgrel=1
+arch=('x86_64' 'arm' 'armv7h' 'armv6h' 'aarch64')
+pkgdesc="Dialer for Plasma Mobile"
+url="https://invent.kde.org/plasma-mobile/plasma-dialer"
+license=('GPL2')
+depends=('kcontacts' 'kirigami2' 'ki18n' 'kconfig' 'kpeople' 'kcoreaddons' 'kdbusaddons'
+ 'knotifications' 'libqofono-git' 'telepathy-qt' 'libpulse' 'libphonenumber')
+makedepends=('extra-cmake-modules' 'qt5-svg' 'qt5-tools')
+source=("https://download.kde.org/stable/plasma-mobile/${pkgver}/${pkgname}-${pkgver}.tar.xz")
+sha256sums=('SKIP')
+
+build() {
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -B build -S "${pkgname}-${pkgver}"
+ cmake --build build --config Release
+}
+
+package() {
+ DESTDIR="${pkgdir}" cmake --install build --config Release
+} \ No newline at end of file