summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f20a9364d770
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = plasma5-applets-audio-device-switcher
+ pkgdesc = KDE Plasma 5 widget to change the default audio output device/sink
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/akrutzler/plasma-audio-device-switcher
+ arch = any
+ license = GPL2
+ makedepends = cmake
+ depends = plasma-workspace
+ source = https://github.com/akrutzler/plasma-audio-device-switcher/archive/0.1.1.tar.gz
+ sha256sums = f42a04afbea630c712a95fd47065ce39ca535ddd0a63d5e92df4dc2e96b0cbb7
+
+pkgname = plasma5-applets-audio-device-switcher
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c45a4ec489ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Kamil ƚliwak <cameel2@gmail.com>
+
+pkgname=plasma5-applets-audio-device-switcher
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="KDE Plasma 5 widget to change the default audio output device/sink"
+arch=('any')
+url="https://github.com/akrutzler/plasma-audio-device-switcher"
+license=('GPL2')
+depends=("plasma-workspace")
+makedepends=("cmake")
+source=(https://github.com/akrutzler/plasma-audio-device-switcher/archive/$pkgver.tar.gz)
+sha256sums=('f42a04afbea630c712a95fd47065ce39ca535ddd0a63d5e92df4dc2e96b0cbb7')
+
+prepare() {
+ mkdir --parents build/
+}
+
+build() {
+ cd build/
+
+ export QT_SELECT=5
+ cmake "../plasma-audio-device-switcher-${pkgver}" -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ cd build/
+
+ make install DESTDIR="$pkgdir/"
+}