summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5c4cfcfdf664..8f66c63dd323 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,19 +15,20 @@ backup=()
install=
source=("https://github.com/I-Dream-in-Code/kde-arch-update-plasmoid/archive/$pkgver.tar.gz")
md5sums=("SKIP")
-pkgver() {
- cd "$srcdir/kde-arch-update-plasmoid"
- # cutting off 'foo-' prefix that presents in the git tag
- printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g')"
-}
+
+# pkgver() {
+# cd "$srcdir/kde-arch-update-plasmoid"
+# # cutting off 'foo-' prefix that presents in the git tag
+# printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g')"
+# }
build() {
- cd kde-arch-update-plasmoid
+ cd "$pkgname-$pkgver"
mkdir build
cd build
cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DKDE_INSTALL_LIBDIR=lib -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
}
package(){
- cd ${srcdir}/kde-arch-update-plasmoid/build
- make DESTDIR="$pkgdir" install
+ cd "$pkgname-$pkgver"
+ make install
}