summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fce0ac3005fb..b5cae83e4d04 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = plasma5-applets-kde-arch-update-notifier-git
pkgdesc = A KDE plasmoid for your system tray notifying you of available updates with AUR Support
- pkgver = 4.0.5
+ pkgver = 4.1.0
pkgrel = 1
url = https://github.com/I-Dream-in-Code/kde-arch-update-plasmoid
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index b4f0c7869754..5cb775654852 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
#Maintainer Mike Harris <mike.a.harris@outlook.com>
pkgname=plasma5-applets-kde-arch-update-notifier-git
-pkgver=4.0.5
+pkgver=4.1.0
pkgrel=1
pkgdesc="A KDE plasmoid for your system tray notifying you of available updates with AUR Support"
url="https://github.com/I-Dream-in-Code/kde-arch-update-plasmoid"
@@ -26,3 +26,8 @@ package(){
make DESTDIR="$pkgdir" install
}
+pkgver() {
+ cd "$srcdir/${pkgname}"
+ # cutting off 'foo-' prefix that presents in the git tag
+ printf "%s" "$(git describe --long | sed 's/^foo-//;s/\([^-]*-g\)/r\1/;s/-/./g')"
+}