summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 306b89cdf519..c81c6b217fe5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,7 +2,7 @@ pkgbase = platypush-git
pkgdesc = Universal multi-platform command executor and automation manager
pkgver = 0.13.9.r0.b27c9ee6
pkgrel = 1
- url = https://github.com/BlackLight/platypush
+ url = https://git.platypush.tech/platypush/platypush
arch = any
license = MIT
depends = python
@@ -20,6 +20,7 @@ pkgbase = platypush-git
depends = python-frozendict
depends = python-bcrypt
depends = python-zeroconf
+ depends = python-pyjwt
optdepends = python-paho-mqtt: MQTT integrations support
optdepends = python-pybluez: Bluetooth support
optdepends = python-gattlib: Low-energy Bluetooth devices support
@@ -28,7 +29,7 @@ pkgbase = platypush-git
optdepends = python-pyserial: Arduino/serial device support
conflicts = platypush
options = !strip
- source = platypush.tar.gz::https://github.com/BlackLight/platypush/archive/master.tar.gz
+ source = platypush.tar.gz::https://git.platypush.tech/platypush/platypush/-/archive/master/platypush-master.tar.gz
sha512sums =
pkgname = platypush-git
diff --git a/PKGBUILD b/PKGBUILD
index 416cf2aae7b3..9f034ee30f64 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,6 @@
# Maintainer: Fabio Manganiello <info@fabiomanganiello.com>
-_pkgname=platypush
-pkgname=${_pkgname}-git
+pkgname=platypush-git
pkgver=0.13.9.r0.b27c9ee6
pkgrel=1
pkgdesc="Universal multi-platform command executor and automation manager"
@@ -17,15 +16,15 @@ optdepends=('python-paho-mqtt: MQTT integrations support'
'python-pyserial: Arduino/serial device support')
conflicts=('platypush')
options=(!strip)
-source=("${_pkgname}.tar.gz::https://github.com/BlackLight/${_pkgname}/archive/master.tar.gz")
+source=("platypush.tar.gz::https://git.platypush.tech/platypush/platypush/-/archive/master/platypush-master.tar.gz")
sha512sums=('')
package() {
- cd "${srcdir}/${_pkgname}-master"
+ cd "${srcdir}/platypush-master"
python3 setup.py install --root="${pkgdir}/" --optimize=1
install -m755 -d "${pkgdir}/usr/lib/systemd/user"
- install -m644 "${srcdir}/${_pkgname}-master/examples/systemd/platypush.service" "${pkgdir}/usr/lib/systemd/user"
+ install -m644 "${srcdir}/platypush-master/examples/systemd/platypush.service" "${pkgdir}/usr/lib/systemd/user"
echo
echo