summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..17c89fc79cbb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = playmusicdecrypter-git
+ pkgdesc = Decrypt MP3 files from Google Play Music offline storage (All Access)
+ pkgver = v1.0.r8.g5a2318a
+ pkgrel = 1
+ url = https://github.com/playmusicdecrypter
+ arch = any
+ license = GPL3
+ depends = python2
+ depends = python2-crypto
+ depends = mutagen
+ optdepends = android-tools
+ source = playmusicdecrypter-git::git+https://github.com/playmusicdecrypter/playmusicdecrypter
+ md5sums = SKIP
+
+pkgname = playmusicdecrypter-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93fe6b1994a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Anna Ivanova <kalterfx@gmail.com>
+
+pkgname='playmusicdecrypter-git'
+
+pkgver='v1.0.r8.g5a2318a'
+function pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/-/.r/;s/-/./'
+}
+
+pkgrel='1'
+pkgdesc='Decrypt MP3 files from Google Play Music offline storage (All Access)'
+url='https://github.com/playmusicdecrypter'
+license=( 'GPL3' )
+
+source=( "$pkgname::git+https://github.com/playmusicdecrypter/playmusicdecrypter" )
+md5sums=( 'SKIP' )
+
+arch=( 'any' )
+depends=( 'python2' 'python2-crypto' 'mutagen' )
+optdepends=( 'android-tools' )
+
+function package() {
+ cd "$pkgname"
+ ./setup.py install --root "$pkgdir"
+ install -Dv -T -- {.,"$pkgdir/usr/share/licenses/$pkgname"}/LICENSE
+}
+