summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa167b005c83..931408284ca3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = playmymusic-git
pkgdesc = Melody is a music player for Pantheon, developed by Artem Anufrij
- pkgver = 2.2.0.r0.gd464825
- pkgrel = 1
+ pkgver = 2.2.1.r9.g22175ba
+ pkgrel = 2
url = http://anufrij.org/melody/
arch = x86_64
license = GPL3
@@ -16,6 +16,8 @@ pkgbase = playmymusic-git
depends = gtk3
optdepends = gst-plugins-bad: "Bad" plugin libraries
optdepends = gst-plugins-ugly: "Ugly" plugin libraries
+ provides = playmymusic
+ conflicts = playmymusic
source = playmymusic-git::git+https://github.com/artemanufrij/playmymusic.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 086924b7ea87..da29aa86ca4c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
pkgname=playmymusic-git
-pkgver=2.2.0.r0.gd464825
-pkgrel=1
+pkgver=2.2.1.r9.g22175ba
+pkgrel=2
pkgdesc="Melody is a music player for Pantheon, developed by Artem Anufrij"
arch=(x86_64)
url="http://anufrij.org/melody/"
@@ -11,6 +11,8 @@ depends=(libgranite.so libsoup gst-plugins-base gst-plugins-good taglib gtk3)
makedepends=(meson vala git)
optdepends=('gst-plugins-bad: "Bad" plugin libraries'
'gst-plugins-ugly: "Ugly" plugin libraries')
+provides=(playmymusic)
+conflicts=(playmymusic)
source=("${pkgname}::git+https://github.com/artemanufrij/playmymusic.git")
sha256sums=('SKIP')
@@ -28,4 +30,5 @@ build() {
package() {
cd "${srcdir}/${pkgname}"
DESTDIR="${pkgdir}" ninja -C build install
+ ln -s /usr/bin/com.github.artemanufrij.playmymusic "$pkgdir/usr/bin/playmymusic"
}