summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 42db2fa6b9c0..62089e3c05ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = playonlinux5-git
pkgdesc = GUI for managing Windows programs under linux (development version based on Java)
pkgver = r1486.178b8e1a
- pkgrel = 3
+ pkgrel = 4
epoch = 2
url = http://www.playonlinux.com/
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 2c50154b7a4b..5afff6ce0c80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@
_pkgname=playonlinux5
pkgname=$_pkgname-git
pkgver=r1486.178b8e1a
-pkgrel=3
+pkgrel=4
epoch=2
pkgdesc="GUI for managing Windows programs under linux (development version based on Java)"
arch=('any')
@@ -44,9 +44,11 @@ build() {
# Set environment
# Use path to Java 8 for users not defaulted to Java 8 yet
- if (( $(archlinux-java get | cut -d "-" -f2) >= 8 )); then
+ if (( $(archlinux-java get | cut -d "-" -f2) < 8 )); then
JAVA_VER=$(archlinux-java get)
export JAVA_HOME="/usr/lib/jvm/${JAVA_VER}"
+ else
+ export JAVA_HOME=$(ls /usr/lib/jvm/java-{8,9}-*/bin/javac 2>/dev/null | cut -d "/" -f-5 | head -1)
fi
# Build