summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD41
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3df4f6df646f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = plexdrive-mongodb
+ pkgdesc = Plexdrive allows you to mount your Google Drive account as read-only fuse filesystem. This version uses mongodb and has hard-drive caching.
+ pkgver = 4.0.0
+ pkgrel = 1
+ url = https://github.com/dweidenfeld/plexdrive
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = armv6h
+ license = MIT
+ makedepends = go
+ depends = fuse
+ provides = plexdrive
+ conflicts = plexdrive-bin
+ conflicts = plexdrive-git
+ conflicts = plexdrive-dev-git
+ conflicts = plexdrive
+ conflicts = plexdrive-mongodb-bin
+ conflicts = plexdrive-sqlite
+ conflicts = plexdrive-bin-sqlite
+ source = https://github.com/dweidenfeld/plexdrive/archive/4.0.0.tar.gz
+ sha256sums = c19fcfead0916900324f5e4ad581cb4d2004b84caf483ec6ebf6ccfcf251e9c0
+
+pkgname = plexdrive-mongodb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a4ec6a79815
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Scott Dickson <scottfoesho AT gmail DOT com>
+
+pkgname=plexdrive-mongodb
+pkgver=4.0.0
+pkgrel=1
+pkgdesc='Plexdrive allows you to mount your Google Drive account as read-only fuse filesystem. This version uses mongodb and has hard-drive caching.'
+arch=('i686' 'x86_64' 'armv7h' 'armv6h')
+url='https://github.com/dweidenfeld/plexdrive'
+license=('MIT')
+depends=('fuse')
+makedepends=('go')
+conflicts=("plexdrive-bin" "plexdrive-git" "plexdrive-dev-git" "plexdrive" "plexdrive-mongodb-bin" "plexdrive-sqlite" "plexdrive-bin-sqlite")
+provides=("plexdrive")
+source=(https://github.com/dweidenfeld/plexdrive/archive/4.0.0.tar.gz)
+sha256sums=('c19fcfead0916900324f5e4ad581cb4d2004b84caf483ec6ebf6ccfcf251e9c0')
+_goroot='/usr/lib/go'
+
+build() {
+ mkdir -p plexdrive/src/github.com/dweidenfeld/plexdrive
+ cd plexdrive
+ export GOROOT="$_goroot"
+ GOPATH=$PWD && export GOPATH
+ cp ../plexdrive-${pkgver}/*.go .
+ mv ../plexdrive-${pkgver}/* src/github.com/dweidenfeld/plexdrive
+ go get bazil.org/fuse
+ go get google.golang.org/api/googleapi
+ go get golang.org/x/sys/unix
+ go get github.com/ogier/pflag
+ go get github.com/claudetech/loggo
+ go get golang.org/x/net/context
+ go get golang.org/x/oauth2
+ go get github.com/mxk/go-flowrate/flowrate
+ go get github.com/orcaman/concurrent-map
+ go get gopkg.in/mgo.v2
+ go build
+}
+
+package() {
+ install -d ${pkgdir}/usr/bin
+ install -Dm755 ${srcdir}/plexdrive/plexdrive ${pkgdir}/usr/bin/
+}