summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
-rw-r--r--plist-viewer.install12
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0f61441d1484
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = plist-viewer
+ pkgdesc = Application to open plist files
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/TingPing/plist-viewer
+ install = plist-viewer.install
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ license = GPL
+ makedepends = gnome-common
+ depends = gtk3
+ depends = libplist
+ depends = desktop-file-utils
+ source = https://github.com/TingPing/plist-viewer/releases/download/0.1.1/plist-viewer-0.1.1.tar.xz
+ sha256sums = 2a0a964e6fa2bbcb7dde09937e3356f36f3e28333499d4f6b4d235b53c9d1d09
+
+pkgname = plist-viewer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d2e2946cff01
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: TingPing tingping@tingping.se
+
+pkgname=plist-viewer
+pkgver=0.1.1
+pkgrel=1
+pkgdesc='Application to open plist files'
+arch=('i686' 'x86_64' 'armv6h')
+url='https://github.com/TingPing/plist-viewer'
+license=('GPL')
+depends=('gtk3' 'libplist' 'desktop-file-utils')
+makedepends=('gnome-common')
+install='plist-viewer.install'
+source=("https://github.com/TingPing/plist-viewer/releases/download/$pkgver/plist-viewer-$pkgver.tar.xz")
+sha256sums=('2a0a964e6fa2bbcb7dde09937e3356f36f3e28333499d4f6b4d235b53c9d1d09')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ ./configure --prefix=/usr
+ make -s
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ DESTDIR="$pkgdir" make install
+}
diff --git a/plist-viewer.install b/plist-viewer.install
new file mode 100644
index 000000000000..8bd1ba053a54
--- /dev/null
+++ b/plist-viewer.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-mime-database usr/share/mime
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}