summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 21 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 46d2c4b6d74a..286dde4277e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = plotbitrate-git
pkgdesc = a script for plotting the bitrate of an audio or video stream over time
- pkgver = 1.0.7.1.r1.g5a5665b
+ pkgver = 1.1.1.0.r1.g59a12ab
pkgrel = 1
url = https://github.com/zeroepoch/plotbitrate
arch = any
@@ -8,12 +8,11 @@ pkgbase = plotbitrate-git
makedepends = git
makedepends = python-setuptools
depends = python-matplotlib
- depends = python-pyqt5
+ depends = python-pyqt6
depends = ffmpeg
- provides = plotbitrate
- conflicts = plotbitrate
- source = plotbitrate::git+https://github.com/zeroepoch/plotbitrate.git
+ provides = python-plotbitrate-git
+ conflicts = python-plotbitrate-git
+ source = git+https://github.com/zeroepoch/plotbitrate.git
md5sums = SKIP
pkgname = plotbitrate-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..aabbfe8ee1f6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*.tar*
+/pkg
+/src
+plotbitrate \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 28d073b67d67..d0f4211d82a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,26 @@
-# Maintainer: sekret, mail=$(echo c2VrcmV0QHBvc3Rlby5zZQo= | base64 -d)
+# Maintainer: Nathaniel Chin <thegamingorangutans+aur at gmail.com>
+# Contributor: sekret, mail=$(echo c2VrcmV0QHBvc3Rlby5zZQo= | base64 -d)
-_pkgname=plotbitrate
-pkgname=$_pkgname-git
-pkgver=1.0.7.1.r1.g5a5665b
+pkgname=plotbitrate-git
+pkgver=1.1.1.0.r1.g59a12ab
pkgrel=1
pkgdesc="a script for plotting the bitrate of an audio or video stream over time"
arch=('any')
url="https://github.com/zeroepoch/plotbitrate"
license=('BSD')
-depends=('python-matplotlib' 'python-pyqt5' 'ffmpeg')
+depends=('python-matplotlib' 'python-pyqt6' 'ffmpeg')
makedepends=('git' 'python-setuptools')
-provides=("$_pkgname")
-conflicts=("$_pkgname")
-source=("$_pkgname::git+$url.git")
+source=("git+https://github.com/zeroepoch/plotbitrate.git")
md5sums=('SKIP')
+provides=('python-plotbitrate-git')
+conflicts=('python-plotbitrate-git')
pkgver() {
- cd "$_pkgname"
- git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+ cd "plotbitrate"
+ git describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
- cd "$_pkgname"
- install -Dm755 "$_pkgname.py" "$pkgdir/usr/bin/$_pkgname"
- mkdir -p "$pkgdir/usr/lib/python$(python3 -V | awk -F. -v OFS=. '{print $1, $2}' | awk '{print $2}')/site-packages/"
- mv frame "$pkgdir/usr/lib/python$(python3 -V | awk -F. -v OFS=. '{print $1, $2}' | awk '{print $2}')/site-packages/"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "${srcdir}/plotbitrate"
+ python setup.py install --root="${pkgdir}/" --optimize=1
}
-
-# vim:set ts=2 sw=2 et: