summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..61bb78cfcc07
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = plymouth-theme-aperture-git
+ pkgdesc = Plymouth theme resembling the Portal loading screen.
+ pkgver = r1.edab46c
+ pkgrel = 1
+ url = https://github.com/irth/plymouth-theme-aperture/
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = plymouth
+ source = https://github.com/irth/plymouth-theme-aperture/archive/master.tar.gz
+ sha256sums = SKIP
+
+pkgname = plymouth-theme-aperture-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f712b2b3cc3e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Wojciech Kwolek <me@irth.pl>
+
+_pkgname=plymouth-theme-aperture
+pkgname="${_pkgname}-git"
+pkgver=r1.edab46c
+pkgrel=1
+pkgdesc='Plymouth theme resembling the Portal loading screen.'
+arch=('any')
+url="https://github.com/irth/${_pkgname}/"
+license=('MIT')
+depends=('plymouth')
+makedepends=('git')
+source=("https://github.com/irth/${_pkgname}/archive/master.tar.gz")
+sha256sums=('SKIP')
+
+package() {
+ cd "${_pkgname}-master"
+
+ _themedir="$pkgdir/usr/share/plymouth/themes/aperture"
+
+ for N in img/*.png aperture.plymouth aperture.script; do
+ install -Dm644 $N "${_themedir}/$N"
+ done
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+}
+
+# vim:set ts=2 sw=2 et: