summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
-rw-r--r--pnmixer-0.5.1-configure.in.patch18
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1bc833a45d6b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = pnmixer
+ pkgdesc = GTK volume mixer applet that runs in the system tray.
+ pkgver = 0.5.1
+ pkgrel = 3
+ url = https://github.com/nicklan/pnmixer
+ arch = i686
+ arch = x86_64
+ groups = pnmixer
+ license = GPL
+ depends = gtk2
+ depends = alsa-lib
+ source = https://github.com/downloads/nicklan/pnmixer/pnmixer-0.5.1.tar.gz
+ source = pnmixer-0.5.1-configure.in.patch
+ md5sums = 2288af95ab280721b39b7c33601d5dd4
+ md5sums = d7aef8eb1cec18858fb2faefe6584276
+
+pkgname = pnmixer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..963ae87873ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+pkgname=pnmixer
+pkgver=0.5.1
+pkgrel=3
+pkgdesc="GTK volume mixer applet that runs in the system tray."
+arch=('i686' 'x86_64')
+license=('GPL')
+url="https://github.com/nicklan/pnmixer"
+groups=('pnmixer')
+depends=('gtk2' 'alsa-lib')
+
+source=(https://github.com/downloads/nicklan/pnmixer/pnmixer-${pkgver}.tar.gz pnmixer-0.5.1-configure.in.patch)
+md5sums=('2288af95ab280721b39b7c33601d5dd4'
+ 'd7aef8eb1cec18858fb2faefe6584276')
+build() {
+ cd $pkgname-$pkgver
+
+ patch -Np0 -i ../pnmixer-0.5.1-configure.in.patch
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}
diff --git a/pnmixer-0.5.1-configure.in.patch b/pnmixer-0.5.1-configure.in.patch
new file mode 100644
index 000000000000..7a7d7222bbf9
--- /dev/null
+++ b/pnmixer-0.5.1-configure.in.patch
@@ -0,0 +1,18 @@
+--- configure.in
++++ configure.in
+@@ -1,14 +1,12 @@
+ dnl Process this file with autoconf to produce a configure script.
+
+-AC_INIT(configure.in)
+-AM_INIT_AUTOMAKE(pnmixer, 0.5.1)
+-AM_CONFIG_HEADER(config.h)
++AC_INIT([pnmixer], [0.5.1])
++AM_INIT_AUTOMAKE
+ AM_MAINTAINER_MODE
+
+ OLD_CFLAGS=$CFLAGS
+ AC_ISC_POSIX
+ AC_PROG_CC
+-AM_PROG_CC_STDC
+ AC_HEADER_STDC
+ CFLAGS=$OLD_CXXFLAGS \ No newline at end of file