summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
-rw-r--r--pnmixer-0.5.1-configure.in.patch18
-rw-r--r--pnmixer.install11
4 files changed, 27 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1bc833a45d6b..33b1314a2baf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
+# Generated by mksrcinfo v7
+# Sun Oct 25 22:42:15 UTC 2015
pkgbase = pnmixer
pkgdesc = GTK volume mixer applet that runs in the system tray.
- pkgver = 0.5.1
- pkgrel = 3
+ pkgver = 0.6.1
+ pkgrel = 1
url = https://github.com/nicklan/pnmixer
+ install = pnmixer.install
arch = i686
arch = x86_64
- groups = pnmixer
license = GPL
depends = gtk2
depends = alsa-lib
- source = https://github.com/downloads/nicklan/pnmixer/pnmixer-0.5.1.tar.gz
- source = pnmixer-0.5.1-configure.in.patch
- md5sums = 2288af95ab280721b39b7c33601d5dd4
- md5sums = d7aef8eb1cec18858fb2faefe6584276
+ depends = libnotify
+ source = https://github.com/nicklan/pnmixer/releases/download/v0.6/pnmixer-0.6.1.tar.gz
+ md5sums = 42e026df389901cc1e0a72db0d256fd0
pkgname = pnmixer
diff --git a/PKGBUILD b/PKGBUILD
index 963ae87873ab..97315b2e5d86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,19 @@
# Maintainer: Brian Bidulock <bidulock@openss7.org>
pkgname=pnmixer
-pkgver=0.5.1
-pkgrel=3
+pkgver=0.6.1
+pkgrel=1
pkgdesc="GTK volume mixer applet that runs in the system tray."
arch=('i686' 'x86_64')
license=('GPL')
url="https://github.com/nicklan/pnmixer"
-groups=('pnmixer')
-depends=('gtk2' 'alsa-lib')
-
-source=(https://github.com/downloads/nicklan/pnmixer/pnmixer-${pkgver}.tar.gz pnmixer-0.5.1-configure.in.patch)
-md5sums=('2288af95ab280721b39b7c33601d5dd4'
- 'd7aef8eb1cec18858fb2faefe6584276')
+depends=('gtk2' 'alsa-lib' 'libnotify')
+install="${pkgname}.install"
+source=("https://github.com/nicklan/pnmixer/releases/download/v0.6/pnmixer-${pkgver}.tar.gz")
+md5sums=('42e026df389901cc1e0a72db0d256fd0')
build() {
cd $pkgname-$pkgver
-
- patch -Np0 -i ../pnmixer-0.5.1-configure.in.patch
- ./autogen.sh
- ./configure --prefix=/usr
- make
+ ./autogen.sh --without-gtk3 --prefix=/usr
+ make V=0
}
package() {
cd $pkgname-$pkgver
diff --git a/pnmixer-0.5.1-configure.in.patch b/pnmixer-0.5.1-configure.in.patch
deleted file mode 100644
index 7a7d7222bbf9..000000000000
--- a/pnmixer-0.5.1-configure.in.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- configure.in
-+++ configure.in
-@@ -1,14 +1,12 @@
- dnl Process this file with autoconf to produce a configure script.
-
--AC_INIT(configure.in)
--AM_INIT_AUTOMAKE(pnmixer, 0.5.1)
--AM_CONFIG_HEADER(config.h)
-+AC_INIT([pnmixer], [0.5.1])
-+AM_INIT_AUTOMAKE
- AM_MAINTAINER_MODE
-
- OLD_CFLAGS=$CFLAGS
- AC_ISC_POSIX
- AC_PROG_CC
--AM_PROG_CC_STDC
- AC_HEADER_STDC
- CFLAGS=$OLD_CXXFLAGS \ No newline at end of file
diff --git a/pnmixer.install b/pnmixer.install
new file mode 100644
index 000000000000..1a05f573e594
--- /dev/null
+++ b/pnmixer.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}