summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rwxr-xr-xclean.fish3
3 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ead338d67a2..2a800bb3944d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = pocket-casts-linux-bin
pkgdesc = Electron wrapper around the Pocket Casts web app with support for MPRIS (media controls)
pkgver = 1.2.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/jgierer12/pocket-casts-linux
arch = x86_64
license = MIT
depends = gtk3
depends = nss
depends = libxss
+ provides = pocket-casts-linux
+ conflicts = pocket-casts-linux
source = https://github.com/jgierer12/pocket-casts-linux/releases/download/v1.2.1/pocket-casts-linux-1.2.1-x64.pacman
source = https://raw.githubusercontent.com/jgierer12/pocket-casts-linux/v1.2.1/LICENSE
md5sums = be21aa678337da7d4a2f62c9b89dcf8c
diff --git a/PKGBUILD b/PKGBUILD
index bc1e3e9a75d6..20ec62a4e578 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,9 @@
# Maintainer: Jonas Gierer <jgierer12@gmail.com>
pkgname=pocket-casts-linux-bin
+provides=('pocket-casts-linux')
+conflicts=('pocket-casts-linux')
pkgver=1.2.1
-pkgrel=1
+pkgrel=2
pkgdesc="Electron wrapper around the Pocket Casts web app with support for MPRIS (media controls)"
arch=('x86_64')
license=('MIT')
@@ -19,7 +21,6 @@ md5sums=('be21aa678337da7d4a2f62c9b89dcf8c'
'04bf690e790df16c6404870cdea950bc')
package() {
- mv "${srcdir}/usr" "${pkgdir}/usr"
- mv "${srcdir}/opt" "${pkgdir}/opt"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cp --recursive $srcdir/{usr,opt} $pkgdir
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
}
diff --git a/clean.fish b/clean.fish
deleted file mode 100755
index a115d325ceff..000000000000
--- a/clean.fish
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/usr/bin/fish
-set --local build_files pkg src LICENSE *.pacman *.tar.xz
-rm -rf $build_files