summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b79aab38557..000119a36599 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,3 +1,5 @@
+# Generated by mksrcinfo v8
+# Tue Feb 2 20:20:37 UTC 2016
pkgbase = pocketsphinx
pkgdesc = Lightweight speech recognition engine, specifically tuned for handheld and mobile devices, though it works equally well on the desktop.
pkgver = 5prealpha
@@ -15,7 +17,7 @@ pkgbase = pocketsphinx
options = !libtool
source = http://downloads.sourceforge.net/cmusphinx/pocketsphinx-5prealpha.tar.gz
source = https://raw.githubusercontent.com/cmusphinx/pocketsphinx/master/LICENSE
- md5sums = e8402e90570935b26745d313c133b376
+ md5sums = dc4246dbeb577731432227ad33289326
md5sums = 93bfe6b712fe592d844ef581e1e53d47
pkgname = pocketsphinx
diff --git a/PKGBUILD b/PKGBUILD
index 46cfd0356d23..3a572c42fe7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ makedepends=('swig')
depends=('sphinxbase=5prealpha' 'python2' 'python' 'gstreamer0.10-base' 'gst-plugins-base-libs')
source=("http://downloads.sourceforge.net/cmusphinx/$pkgname-$pkgver.tar.gz"
"https://raw.githubusercontent.com/cmusphinx/pocketsphinx/master/LICENSE")
-md5sums=('e8402e90570935b26745d313c133b376'
+md5sums=('dc4246dbeb577731432227ad33289326'
'93bfe6b712fe592d844ef581e1e53d47')
options=('!libtool')
@@ -22,10 +22,14 @@ prepare() {
}
build() {
+
+ msg2 "Building python3 environment"
cd "$pkgname-$pkgver-py3"
./configure --prefix=/usr
make
+
+ msg2 "Building python2 environment"
cd "../$pkgname-$pkgver-py2"
export PYTHON=/usr/bin/python2
./configure --prefix=/usr