summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
2 files changed, 21 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f7e8d6f8495..8cd4b1f2c641 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,24 @@
# Generated by mksrcinfo v8
-# Tue Mar 15 09:55:38 UTC 2016
+# Wed Jun 1 10:12:39 UTC 2016
pkgbase = pocketsphinx
pkgdesc = Lightweight speech recognition engine, specifically tuned for handheld and mobile devices, though it works equally well on the desktop.
pkgver = 5prealpha
- pkgrel = 4
+ pkgrel = 5
url = http://cmusphinx.sourceforge.net
arch = i686
arch = x86_64
license = BSD
makedepends = swig
+ makedepends = python2
+ makedepends = python
depends = sphinxbase=5prealpha
- depends = python2
- depends = python
depends = gstreamer0.10-base
depends = gst-plugins-base-libs
options = !libtool
source = http://downloads.sourceforge.net/cmusphinx/pocketsphinx-5prealpha.tar.gz
source = https://raw.githubusercontent.com/cmusphinx/pocketsphinx/master/LICENSE
- md5sums = 2c4fb3a1318bb2470997ab7eb98ef69a
- md5sums = 93bfe6b712fe592d844ef581e1e53d47
+ sha256sums = ad9f5f5c5ce79ff87b63d527f8f4d3e2f54c0c1da53793895991a8849ca47701
+ sha256sums = fcf5c4e41ae81f704ed70f1511146272ef0f0ca7b97088d11d72896b56a189f5
pkgname = pocketsphinx
diff --git a/PKGBUILD b/PKGBUILD
index a0b959dbd0df..4ad2b6911d9d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,30 @@
-# Maintainer: Marco Pompili <marcs DOT pompili AT gmail DOT com>
+# Maintainer: Marco Pompili <aur AT emarcs DOT org>
# Contributor: Ben Duffield <bavardage AT archlinux.us>
+# Contributor: Martchus <martchus@gmx.net>
pkgname=pocketsphinx
pkgver=5prealpha
-pkgrel=4
+pkgrel=5
pkgdesc='Lightweight speech recognition engine, specifically tuned for handheld and mobile devices, though it works equally well on the desktop.'
arch=('i686' 'x86_64')
url='http://cmusphinx.sourceforge.net'
license=('BSD')
-makedepends=('swig')
-depends=('sphinxbase=5prealpha' 'python2' 'python' 'gstreamer0.10-base' 'gst-plugins-base-libs')
+makedepends=('swig' 'python2' 'python')
+depends=('sphinxbase=5prealpha' 'gstreamer0.10-base' 'gst-plugins-base-libs')
source=("http://downloads.sourceforge.net/cmusphinx/$pkgname-$pkgver.tar.gz"
"https://raw.githubusercontent.com/cmusphinx/pocketsphinx/master/LICENSE")
-md5sums=('2c4fb3a1318bb2470997ab7eb98ef69a'
- '93bfe6b712fe592d844ef581e1e53d47')
+sha256sums=('ad9f5f5c5ce79ff87b63d527f8f4d3e2f54c0c1da53793895991a8849ca47701'
+ 'fcf5c4e41ae81f704ed70f1511146272ef0f0ca7b97088d11d72896b56a189f5')
options=('!libtool')
prepare() {
+ cd "$pkgname-$pkgver"
+
+ msg2 "Reconfiguring project for current version of Automake"
+ autoreconf -ivf > /dev/null
+
+ cd ..
+
cp -R "$pkgname-$pkgver" "$pkgname-$pkgver-py2"
cp -R "$pkgname-$pkgver" "$pkgname-$pkgver-py3"
}
@@ -24,6 +32,7 @@ prepare() {
build() {
msg2 "Building python3 environment"
+ export PYTHON=/usr/bin/python
cd "$pkgname-$pkgver-py3"
./configure --prefix=/usr
make