summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD21
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..18b06d0e7e6f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Tue Mar 7 04:19:01 UTC 2017
+pkgbase = pokoy
+ pkgdesc = Lightweight daemon for X that helps prevent RSI and other computer related stress
+ pkgver = 0.2.2
+ pkgrel = 1
+ url = https://github.com/ttygde/pokoy
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = xcb-util-wm
+ depends = xcb-util-keysyms
+ source = pokoy-0.2.2.tar.gz::https://github.com/ttygde/pokoy/archive/v0.2.2.tar.gz
+ md5sums = ea74913145ee81a63189a9396c246af6
+
+pkgname = pokoy
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e6b6b4b8077d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.lz
+src/
+pkg/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..94badad69da3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Contrinutor: Anton Leontiev <scileont /at/ gmail.com>
+
+pkgname=pokoy
+pkgver=0.2.2
+pkgrel=1
+pkgdesc='Lightweight daemon for X that helps prevent RSI and other computer related stress'
+arch=('i686' 'x86_64')
+url='https://github.com/ttygde/pokoy'
+license=('GPL2')
+depends=('xcb-util-wm' 'xcb-util-keysyms')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/ttygde/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('ea74913145ee81a63189a9396c246af6')
+
+build() {
+ make -C $pkgname-$pkgver
+}
+
+package() {
+ make -C $pkgname-$pkgver DESTDIR="$pkgdir" install
+}
+