summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD23
-rw-r--r--polar-bookshelf-bin.install19
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a82a46d7c2ad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = polar-bookshelf-bin
+ pkgdesc = Polar Bookshelf
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/burtonator/polar-bookshelf
+ install = polar-bookshelf-bin.install
+ arch = x86_64
+ license = GPL2
+ depends = desktop-file-utils
+ depends = gconf
+ depends = hicolor-icon-theme
+ depends = libappindicator-gtk2
+ depends = libnotify
+ depends = libxss
+ depends = libxtst
+ depends = nss
+ options = !strip
+ options = !emptydirs
+ source_x86_64 = https://github.com/burtonator/polar-bookshelf/releases/download/v1.0.1/polar-bookshelf-1.0.1-amd64.deb
+ sha512sums_x86_64 = 67ae55e02a0c08d59d0982f406f2932060d286606887a6ada9a13e9bbf543f569b1393c24d82d73675c7a5b245ff8f453c01a028180a6efb1d53221e39fae542
+
+pkgname = polar-bookshelf-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d7825ec4c41
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: kausban <mail at kausban com>
+pkgname=polar-bookshelf-bin
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="Polar Bookshelf"
+arch=('x86_64')
+url="https://github.com/burtonator/polar-bookshelf"
+license=('GPL2')
+groups=('')
+depends=('desktop-file-utils' 'gconf' 'hicolor-icon-theme' 'libappindicator-gtk2' 'libnotify' 'libxss' 'libxtst' 'nss')
+options=('!strip' '!emptydirs')
+install=${pkgname}.install
+source_x86_64=("https://github.com/burtonator/polar-bookshelf/releases/download/v"$pkgver"/polar-bookshelf-"$pkgver"-amd64.deb")
+sha512sums_x86_64=('67ae55e02a0c08d59d0982f406f2932060d286606887a6ada9a13e9bbf543f569b1393c24d82d73675c7a5b245ff8f453c01a028180a6efb1d53221e39fae542')
+
+package(){
+
+ # Extract package data
+ tar xf data.tar.xz -C "${pkgdir}"
+
+ install -D -m644 "${pkgdir}/opt/Polar Bookshelf/resources/app.asar.unpacked/node_modules/term-size/license" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+}
diff --git a/polar-bookshelf-bin.install b/polar-bookshelf-bin.install
new file mode 100644
index 000000000000..a10355013d62
--- /dev/null
+++ b/polar-bookshelf-bin.install
@@ -0,0 +1,19 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
+ # Link to the binary
+ ln -sf '/opt/Polar Bookshelf/polar-bookshelf' '/usr/bin/polar-bookshelf'
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
+ # Delete the link to the binary
+ rm -f '/usr/bin/polar-bookshelf'
+ update-desktop-database -q
+}