summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD18
2 files changed, 14 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed18e756d1c5..28334706ca71 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = polybar
pkgdesc = A fast and easy-to-use status bar
pkgver = 3.4.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/polybar/polybar
install = polybar.install
arch = i686
@@ -12,22 +12,22 @@ pkgbase = polybar
makedepends = python
makedepends = python2
makedepends = pkg-config
+ makedepends = i3-wm
depends = cairo
depends = xcb-util-image
depends = xcb-util-wm
depends = xcb-util-xrm
depends = xcb-util-cursor
- optdepends = alsa-lib: alsa module support
- optdepends = pulseaudio: pulseaudio module support
- optdepends = libmpdclient: mpd module support
- optdepends = libnl: network module support
- optdepends = wireless_tools: network module support (legacy)
- optdepends = jsoncpp: i3 module support
+ depends = alsa-lib
+ depends = libpulse
+ depends = libmpdclient
+ depends = libnl
+ depends = jsoncpp
+ depends = curl
optdepends = i3-wm: i3 module support
optdepends = ttf-unifont: Font used in example config
optdepends = siji-git: Font used in example config
optdepends = xorg-fonts-misc: Font used in example config
- optdepends = curl: github module support
conflicts = polybar-git
source = https://github.com/polybar/polybar/releases/download/3.4.0/polybar-3.4.0.tar
sha256sums = 69a098f22d7a72eb594030aff687801252b18520b097c12f5c7894a99c4bcd1b
diff --git a/PKGBUILD b/PKGBUILD
index e9c8cb427de6..6654fa3af375 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,18 @@
# Contributor: Michael Carlberg <c@rlberg.se>
pkgname=polybar
pkgver=3.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="A fast and easy-to-use status bar"
arch=("i686" "x86_64")
url="https://github.com/polybar/polybar"
license=("MIT")
-depends=("cairo" "xcb-util-image" "xcb-util-wm" "xcb-util-xrm" "xcb-util-cursor")
-optdepends=("alsa-lib: alsa module support"
- "pulseaudio: pulseaudio module support"
- "libmpdclient: mpd module support"
- "libnl: network module support"
- "wireless_tools: network module support (legacy)"
- "jsoncpp: i3 module support"
- "i3-wm: i3 module support"
+depends=("cairo" "xcb-util-image" "xcb-util-wm" "xcb-util-xrm" "xcb-util-cursor"
+ "alsa-lib" "libpulse" "libmpdclient" "libnl" "jsoncpp" "curl")
+optdepends=("i3-wm: i3 module support"
"ttf-unifont: Font used in example config"
"siji-git: Font used in example config"
- "xorg-fonts-misc: Font used in example config"
- "curl: github module support")
-makedepends=("cmake" "git" "python" "python2" "pkg-config")
+ "xorg-fonts-misc: Font used in example config")
+makedepends=("cmake" "git" "python" "python2" "pkg-config" "i3-wm")
conflicts=("polybar-git")
install="${pkgname}.install"
source=(${url}/releases/download/${pkgver}/polybar-${pkgver}.tar)