summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0febf1cb9e2a..265eeeb277a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = polybar
pkgdesc = A fast and easy-to-use status bar
- pkgver = 3.0.5
- pkgrel = 4
+ pkgver = 3.1.0
+ pkgrel = 1
url = https://github.com/jaagr/polybar
install = polybar.install
arch = i686
arch = x86_64
license = MIT
- makedepends = clang
makedepends = cmake
makedepends = git
makedepends = python
@@ -26,7 +25,7 @@ pkgbase = polybar
optdepends = siji-git: Font used in example config
optdepends = curl: github module support
conflicts = polybar-git
- source = polybar::git+https://github.com/jaagr/polybar.git#tag=3.0.5
+ source = polybar::git+https://github.com/jaagr/polybar.git#tag=3.1.0
md5sums = SKIP
pkgname = polybar
diff --git a/PKGBUILD b/PKGBUILD
index 548c7b1840cb..56c41d4786f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Michael Carlberg <c@rlberg.se>
# Contributor: Michael Carlberg <c@rlberg.se>
pkgname=polybar
-pkgver=3.0.5
-pkgrel=4
+pkgver=3.1.0
+pkgrel=1
pkgdesc="A fast and easy-to-use status bar"
arch=("i686" "x86_64")
url="https://github.com/jaagr/polybar"
@@ -16,7 +16,7 @@ optdepends=("alsa-lib: volume module support"
"ttf-unifont: Font used in example config"
"siji-git: Font used in example config"
"curl: github module support")
-makedepends=("clang" "cmake" "git" "python" "python2" "pkg-config")
+makedepends=("cmake" "git" "python" "python2" "pkg-config")
conflicts=("polybar-git")
install="${pkgname}.install"
source=("${pkgname}::git+${url}.git#tag=${pkgver}")
@@ -24,13 +24,12 @@ md5sums=("SKIP")
prepare() {
git -C "${pkgname}" submodule update --init --recursive
- git -C "${pkgname}" cherry-pick -n d35abc7620c8f06618b4708d9a969dfa2f309e96
mkdir -p "${pkgname}/build"
}
build() {
cd "${pkgname}/build" || exit 1
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_C_COMPILER="clang" -DCMAKE_CXX_COMPILER="clang++" ..
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
cmake --build .
}