summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e24bf987b5a..d4a830374d19 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = polybar
pkgdesc = A fast and easy-to-use status bar
- pkgver = 3.4.3
- pkgrel = 2
+ pkgver = 3.5.0
+ pkgrel = 1
url = https://github.com/polybar/polybar
install = polybar.install
arch = i686
@@ -29,8 +29,8 @@ pkgbase = polybar
optdepends = siji-git: Font used in example config
optdepends = xorg-fonts-misc: Font used in example config
conflicts = polybar-git
- source = https://github.com/polybar/polybar/releases/download/3.4.3/polybar-3.4.3.tar
- sha256sums = d4ed121c1d3960493f8268f966d65a94d94c4646a4abb131687e37b63616822f
+ source = https://github.com/polybar/polybar/releases/download/3.5.0/polybar-3.5.0.tar
+ sha256sums = e8c1798c195854852fc7c99703287294123381101b371f171d4aa540aeb17afd
pkgname = polybar
diff --git a/PKGBUILD b/PKGBUILD
index f347d6ff7de8..fa68c05fe24d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Patrick Ziegler <p.ziegler96@gmail.com>
pkgname=polybar
-pkgver=3.4.3
-pkgrel=2
+pkgver=3.5.0
+pkgrel=1
pkgdesc="A fast and easy-to-use status bar"
arch=("i686" "x86_64")
url="https://github.com/polybar/polybar"
@@ -16,7 +16,7 @@ makedepends=("cmake" "git" "python" "pkg-config" "python-sphinx" "i3-wm")
conflicts=("polybar-git")
install="${pkgname}.install"
source=(${url}/releases/download/${pkgver}/polybar-${pkgver}.tar)
-sha256sums=('d4ed121c1d3960493f8268f966d65a94d94c4646a4abb131687e37b63616822f')
+sha256sums=('e8c1798c195854852fc7c99703287294123381101b371f171d4aa540aeb17afd')
prepare() {
mkdir -p "${pkgname}/build"
@@ -24,7 +24,8 @@ prepare() {
build() {
cd "${pkgname}/build" || exit 1
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ..
+ # Force cmake to use system python (to detect xcbgen)
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DPYTHON_EXECUTABLE=/usr/bin/python3 ..
cmake --build .
}