summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD69
2 files changed, 105 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..734c692f4404
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = pom-ng-git
+ pkgdesc = Packet-o-Matic real time network packet capture forensic tool
+ pkgver = 0.0.18.r53.g497861c
+ pkgrel = 1
+ url = http://www.packet-o-matic.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = gcc
+ makedepends = binutils
+ makedepends = make
+ makedepends = libtool
+ makedepends = pkg-config
+ depends = libxml2
+ depends = libmicrohttpd
+ depends = xmlrpc-c
+ depends = lua51
+ depends = uthash
+ depends = file
+ depends = libpcap
+ depends = zlib
+ depends = libexif
+ depends = sqlite
+ optdepends = libjpeg: analyze jpeg images
+ optdepends = libexif: parse exif data from jpeg images
+ optdepends = pom-ng-webui: view and manage from a browser
+ optdepends = pom-ng-console: view and manage from a console
+ optdepends = pom-ng-addons
+ provides = pom-ng=0.0.18
+ conflicts = pom-ng
+ source = POM-NG-GIT::git://github.com/gmsoft-tuxicoman/pom-ng.git
+ sha256sums = SKIP
+
+pkgname = pom-ng-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..448d93d010f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,69 @@
+# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+# Contributor: Gatien Bovyn <gatien.bovyn@gmail.com>
+# Contributor: Guy Martin <gmsoft@tuxicoman.be>
+
+# TODO: A systemd service
+# TODO: How to fix registry: Configuration "startup" not found in the database
+
+# This package functions as a server only.
+# To use you must install the console or the webui interface
+
+set -u
+_pkgname='pom-ng'
+pkgname="${_pkgname}-git"
+pkgver=0.0.18.r53.g497861c
+pkgrel=1
+pkgdesc='Packet-o-Matic real time network packet capture forensic tool'
+arch=('i686' 'x86_64')
+url='http://www.packet-o-matic.org/'
+license=('GPL')
+depends=('libxml2' 'libmicrohttpd' 'xmlrpc-c' 'lua51' 'uthash' 'file' 'libpcap' 'zlib' 'libexif' 'sqlite')
+optdepends=(
+ 'libjpeg: analyze jpeg images'
+ 'libexif: parse exif data from jpeg images'
+ "${_pkgname}-webui: view and manage from a browser"
+ "${_pkgname}-console: view and manage from a console"
+ "${_pkgname}-addons"
+ #'postgresql: store configurations and other (pick one)' # These will be enabled when postgre is supported. For now sqlite is required.
+ #'sqlite: store configurations and other (pick one)'
+)
+makedepends=('git' 'gcc' 'binutils' 'make' 'libtool' 'pkg-config')
+provides=("${_pkgname}=${pkgver%%.r*}")
+conflicts=("${_pkgname}")
+_srcdir="${pkgname^^}"
+_giturl="https://github.com/gmsoft-tuxicoman/${_pkgname}"
+_verwatch=("${_giturl}/releases" "${_giturl#*github.com}/archive/v\(.*\)\.tar\.gz" 'l')
+source=("${_srcdir}::${_giturl//https:/git:}.git")
+sha256sums=('SKIP')
+
+pkgver () {
+ set -u
+ cd "${_srcdir}"
+ git describe --long --tags | sed -e 's:^v::g' -e 's/\([^-]*-g\)/r\1/' -e 's/-/./g'
+ set +u
+}
+
+prepare() {
+ set -u
+ cd "${_srcdir}"
+ autoreconf -f -i
+ ./configure --prefix='/usr'
+ #cp -p '/usr/include/libexif/exif-data.h' .
+ set +u
+}
+
+build() {
+ set -u
+ cd "${_srcdir}"
+ make -s -j "$(nproc)"
+ set +u
+}
+
+package() {
+ set -u
+ cd "${_srcdir}"
+ make DESTDIR="${pkgdir}" install
+ install -d "${pkgdir}/usr/share/${_pkgname}/addons"
+ set +u
+}
+set +u