summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD32
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db789dd77d02
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = pong
+ pkgdesc = pong is not ping. pong is CLI game.
+ pkgver = 2.01
+ pkgrel = 1
+ url = https://github.com/kurehajime/pong-command
+ arch = any
+ license = MIT
+ makedepends = git
+ source = pong::https://github.com/kurehajime/pong-command/archive/2.01.tar.gz
+ md5sums = SKIP
+
+pkgname = pong
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c7a4cd88ff58
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/*.tar.xz
+/src
+/pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0715c4fa4e8b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Denys Vitali <denys@denv.it>
+pkgname=pong
+pkgver=2.01
+pkgrel=1
+pkgdesc="pong is not ping. pong is CLI game. "
+reponame=pong-command
+arch=('any')
+url="https://github.com/kurehajime/pong-command"
+license=('MIT')
+groups=()
+makedepends=('git')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(${pkgname}::"https://github.com/kurehajime/pong-command/archive/${pkgver}.tar.gz")
+md5sums=('SKIP')
+
+
+build() {
+ cd "$srcdir/${reponame}-${pkgver}/"
+ go build -o "$srcdir/${reponame}-${pkgver}/pong_out" -i pong/*
+}
+
+
+package() {
+ install -m755 -d "${pkgdir}/usr/bin"
+ cp "${srcdir}/${reponame}-${pkgver}/pong_out" "${pkgdir}/usr/bin/pong"
+}