summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5ff093e2957b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = pony
+ pkgdesc = Can I have a pony?
+ pkgver = 1.0
+ pkgrel = 3
+ url = http://hackage.haskell.org/package/pony
+ arch = i686
+ arch = x86_64
+ license = custom:BSD3
+ makedepends = ghc
+ depends = gmp
+ options = strip
+ source = http://hackage.haskell.org/packages/archive/pony/1.0/pony-1.0.tar.gz
+ md5sums = 10ce264fbbe185a3f6290017c5ea58b2
+
+pkgname = pony
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91f232ba7865
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+# Previous maintainer: Arch Haskell Team <arch-haskell@haskell.org>
+
+_hkgname=pony
+pkgname=pony
+pkgver=1.0
+pkgrel=3
+pkgdesc="Can I have a pony?"
+url="http://hackage.haskell.org/package/${_hkgname}"
+license=('custom:BSD3')
+arch=('i686' 'x86_64')
+makedepends=('ghc')
+depends=('gmp')
+options=('strip')
+source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
+build() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ runhaskell Setup configure --prefix=/usr --docdir=/usr/share/doc/${pkgname} -O
+ runhaskell Setup build
+}
+package() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ runhaskell Setup copy --destdir=${pkgdir}
+ install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ rm -f ${pkgdir}/usr/share/doc/${pkgname}/LICENSE
+}
+md5sums=('10ce264fbbe185a3f6290017c5ea58b2')