summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD15
-rw-r--r--fix-chrome-nokto-install.patch19
4 files changed, 12 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5222c1ee922f..50e7249003c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue May 9 02:38:28 UTC 2017
+# Mon May 15 17:58:41 UTC 2017
pkgbase = pop-gtk-theme
pkgdesc = System76 Pop GTK+ Theme (GNOME, Budgie, XFCE, MATE)
- pkgver = 1.0.8
+ pkgver = 1.2.1
pkgrel = 1
url = https://github.com/system76/pop-gtk-theme
arch = any
@@ -19,10 +19,8 @@ pkgbase = pop-gtk-theme
makedepends = pkg-config
makedepends = sassc>=3.3.2
makedepends = parallel
- source = https://launchpad.net/~system76-dev/+archive/ubuntu/stable/+files/system76-pop-gtk-theme_1.0.8.tar.xz
- source = fix-chrome-nokto-install.patch
- sha256sums = 8d38e1b64bbe3668103e5abced61135f2c4955848b0cd3df1da52464e6cc3932
- sha256sums = 11d334221e2fb8edb36d6e5ca50dd0083c12695394a66f61aa7846da5dbfa71c
+ source = https://github.com/system76/pop-gtk-theme/archive/v1.2.1/pop-gtk-theme-1.2.1.tar.gz
+ sha256sums = 1b637fc557362943507210d5bc1f6af3baefed87828d2ad47013fd823c906784
pkgname = pop-gtk-theme
depends = gtk2>=2.24.30
diff --git a/.gitignore b/.gitignore
index 08717c5ddaf7..71210bc43107 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,10 +1,10 @@
# sources
-*.tar.xz
+*.tar.gz
# build logs
*-build.log
*-namcap.log
-*-package.log
+*-package*.log
*-prepare.log
# packages
diff --git a/PKGBUILD b/PKGBUILD
index 26fbbdd33acc..c989a89a80ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Carl George < arch at cgtx dot us >
pkgname='pop-gtk-theme'
-pkgver=1.0.8
+pkgver=1.2.1
pkgrel=1
pkgdesc='System76 Pop GTK+ Theme (GNOME, Budgie, XFCE, MATE)'
arch=('any')
@@ -20,14 +20,11 @@ makedepends=(
'sassc>=3.3.2'
'parallel'
)
-source=("https://launchpad.net/~system76-dev/+archive/ubuntu/stable/+files/system76-pop-gtk-theme_$pkgver.tar.xz"
- 'fix-chrome-nokto-install.patch')
-sha256sums=('8d38e1b64bbe3668103e5abced61135f2c4955848b0cd3df1da52464e6cc3932'
- '11d334221e2fb8edb36d6e5ca50dd0083c12695394a66f61aa7846da5dbfa71c')
+source=("$url/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('1b637fc557362943507210d5bc1f6af3baefed87828d2ad47013fd823c906784')
prepare() {
- patch -p0 -i fix-chrome-nokto-install.patch
- cd gtk-theme
+ cd "$pkgname-$pkgver"
./autogen.sh \
--disable-flashback \
--disable-unity \
@@ -39,7 +36,7 @@ prepare() {
}
build() {
- cd gtk-theme
+ cd "$pkgname-$pkgver"
make
}
@@ -56,6 +53,6 @@ package() {
'xfdesktop>=4.12.2: XFCE desktop'
'mate-desktop>=1.14.0: MATE desktop'
)
- cd gtk-theme
+ cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
}
diff --git a/fix-chrome-nokto-install.patch b/fix-chrome-nokto-install.patch
deleted file mode 100644
index 1079c2af3eda..000000000000
--- a/fix-chrome-nokto-install.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff -Naurp gtk-theme.orig/extra/Makefile.am gtk-theme/extra/Makefile.am
---- gtk-theme.orig/extra/Makefile.am 2017-04-27 16:26:47.000000000 -0500
-+++ gtk-theme/extra/Makefile.am 2017-05-08 21:13:52.053126399 -0500
-@@ -35,7 +35,6 @@ if ENABLE_CHROME
- $(MKDIR_P) $(adaptadir)/chrome
-
- cp -Rv $(chrome_file) $(adaptadir)/chrome
-- cp -Rv $(chrome_nokto_file) $(noktodir)/chrome
-
- cd $(adaptadir)
- ln -sf ../Pop/chrome $(adaptaetadir)/chrome
-@@ -43,6 +42,7 @@ if ENABLE_CHROME
-
- if ENABLE_NOKTO
- $(MKDIR_P) $(noktodir)/chrome
-+ cp -Rv $(chrome_nokto_file) $(noktodir)/chrome
- cd $(adaptadir)
- ln -sf ../Pop-Nokto/chrome $(noktoetadir)/chrome
- endif