summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 8 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e91602477186..962b85d82ee4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = popcorntime-git
pkgdesc = Stream movies and TV shows from torrents
- pkgver = r6157.5aabb4b
+ pkgver = r6211.db796345
pkgrel = 1
url = https://popcorntime.sh
arch = i686
@@ -8,9 +8,6 @@ pkgbase = popcorntime-git
license = GPL3
makedepends = git
makedepends = npm
- makedepends = bower
- makedepends = nodejs-grunt-cli
- makedepends = gulp
depends = alsa-lib
depends = gconf
depends = gtk2
@@ -18,7 +15,6 @@ pkgbase = popcorntime-git
depends = ttf-font
depends = libxtst
depends = libnotify
- depends = desktop-file-utils
provides = popcorntime
conflicts = popcorntime
conflicts = popcorn-time-ce
diff --git a/PKGBUILD b/PKGBUILD
index 06cd2c307da1..95af7338de22 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,14 @@
pkgname=popcorntime-git
_pkgname=popcorntime
_gitname=popcorn-desktop
-pkgver=r6157.5aabb4b
+pkgver=r6211.db796345
pkgrel=1
pkgdesc="Stream movies and TV shows from torrents"
arch=('i686' 'x86_64')
url="https://popcorntime.sh"
license=('GPL3')
-depends=('alsa-lib' 'gconf' 'gtk2' 'nss' 'ttf-font' 'libxtst' 'libnotify' 'desktop-file-utils')
-makedepends=('git' 'npm' 'bower' 'nodejs-grunt-cli' 'gulp')
+depends=('alsa-lib' 'gconf' 'gtk2' 'nss' 'ttf-font' 'libxtst' 'libnotify')
+makedepends=('git' 'npm')
conflicts=('popcorntime' 'popcorn-time-ce')
provides=('popcorntime')
options=('!strip')
@@ -29,14 +29,11 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "${_gitname}"
- npm install
-}
-
build() {
cd "${_gitname}"
- gulp build -p ${_platform}
+
+ npm install
+ node_modules/.bin/gulp build --platforms ${_platform}
}
package() {
@@ -56,4 +53,5 @@ package() {
# Copy complete content of source archive to /usr/share/${_pkgname}/
cp -a "${_bpath}"/* "${pkgdir}/usr/share/${_pkgname}/"
+ chmod +x "${pkgdir}/usr/share/${_pkgname}/Popcorn-Time"
}