summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD11
-rw-r--r--nwjs-patch.diff13
2 files changed, 22 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 97dff60e3f6d..b237638c93eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,15 +16,22 @@ provides=(popcorntime)
conflicts=(popcorntime popcorntime-ce)
options=(!strip)
source=(git+https://github.com/popcorn-official/popcorn-desktop#branch=development
- popcorntime.desktop)
+ popcorntime.desktop
+ nwjs-patch.diff)
sha512sums=('SKIP'
- 'abf5d406467422168944244b95eac0d2c23ca4140cd803afeea852e9a15a5176a019a5772be919234fe01ceec0d8d135158900e828144b0079018015662f7dcd')
+ 'abf5d406467422168944244b95eac0d2c23ca4140cd803afeea852e9a15a5176a019a5772be919234fe01ceec0d8d135158900e828144b0079018015662f7dcd'
+ '4749e7e521b0e784a956231baccb0841a0f28a7f7415d6e47f24ba3138e4fe88c2e6d9defcd10acbe86718a42a6b99dcbddaa20d95df584c71ad2ad653a180cf')
pkgver() {
cd popcorn-desktop
echo $(git tag)+r$(git rev-list --count HEAD)+g$(git rev-parse --short HEAD)
}
+prepare() {
+ cd popcorn-desktop
+ patch -p1 --binary < "$srcdir/nwjs-patch.diff"
+}
+
build() {
cd popcorn-desktop
yarn config set yarn-offline-mirror ./node_modules/
diff --git a/nwjs-patch.diff b/nwjs-patch.diff
new file mode 100644
index 000000000000..b76a0dea7252
--- /dev/null
+++ b/nwjs-patch.diff
@@ -0,0 +1,13 @@
+diff --git a/gulpfile.js b/gulpfile.js
+index 989cb2f4..3124e8be 100644
+--- a/gulpfile.js
++++ b/gulpfile.js
+@@ -3,7 +3,7 @@
+ /********
+ * setup *
+ ********/
+-const nwVersion = '0.33.4',
++const nwVersion = '0.39.2',
+ availablePlatforms = ['linux32', 'linux64', 'win32', 'win64', 'osx64'],
+ releasesDir = 'build',
+ nwFlavor = 'sdk';